<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.4.5.19" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>Juneteenth Festival of Buffalo -2020 | wgrz.com</title>
    <script>(function () {
    function supportsStaticImport() {
        var script = document.createElement('script');
        return 'noModule' in script;
    }

    window.tegna = window.tegna || {};
    window.tegna.supportsJavascript = supportsStaticImport();

    if (window.tegna.supportsJavascript) {
        document.documentElement.classList.remove('root_js_disabled');
        window.tegna.performance = {
            'received': {
                'time': window.performance.now()
            }
        };
        window.tegna.ie = !!window.MSInputMethodContext && !!document.documentMode;
    } else {
        document.documentElement.classList.add('root_ie_true');
    }
})();</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #d81f32;
    --theme-secondary: #455b6d;
}
</style>

<link rel="preload" href="/modules.min.css?ver=4.5.19" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };" />
<noscript><link rel="stylesheet" href="/modules.min.css?ver=4.5.19"></noscript>
<link rel="preload" href="/assets/js-libs/swiper/swiper.min.js?ver=4.5.19" as="script" type="text/javascript" />
<link rel="preload" href="/modules.min.js?ver=4.5.19" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
            <link rel="icon" href="/assets/favicons/WGRZ.png?ver=2.4.5.19" />
    <link rel="canonical" href="https://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" />
    <link rel="alternate" href="https://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" />
                <link rel="amphtml" href="https://www.wgrz.com/amp/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" />
        <meta itemprop="datePublished" content="5/22/2020 4:48:02 PM" />
        <meta itemprop="dateModified" content="5/22/2020 4:48:01 PM" />
        <meta itemprop="url" content="https://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" />
        <meta itemprop="magnet:custom" name="category" content="entertainment" />
        <meta property="og:url" content="https://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
        <meta property="og:title" content="Juneteenth Festival of Buffalo -2020">
        <meta property="og:description" content="On-line Virtual Celebration, June 13th &amp; 14th">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="5/22/2020 4:48:02 PM" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta name="twitter:title" content="Juneteenth Festival of Buffalo -2020">
        <meta name="twitter:image:src" content="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_360x203.jpg">
        <meta name="twitter:card" content="summary">
        <meta name="twitter:site" content="WGRZ">
        <meta name="twitter:description" content="On-line Virtual Celebration, June 13th &amp; 14th">
        <meta name="twitter:domain" content="www.wgrz.com">
    

            <meta name="viewport" content="width=1170" />
            <meta name="site" content="wgrz.com" />
            <meta name="description" content="On-line Virtual Celebration, June 13th &amp; 14th" />
            <meta property="fb:app_id" content="214344422473170" />
            <meta property="og:site_name" content="wgrz.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="5/22/2020 4:48:02 PM" />
    <script>(function() {
    window.tegna = window.tegna || {};

    // loadcss
    !function (t) { "use strict"; t.loadCSS || (t.loadCSS = function () { }); var e = loadCSS.relpreload = {}; if (e.support = function () { var e; try { e = t.document.createElement("link").relList.supports("preload") } catch (t) { e = !1 } return function () { return e } }(), e.bindMediaToggle = function (t) { var e = t.media || "all"; function a() { t.media = e } t.addEventListener ? t.addEventListener("load", a) : t.attachEvent && t.attachEvent("onload", a), setTimeout(function () { t.rel = "stylesheet", t.media = "only x" }), setTimeout(a, 3e3) }, e.poly = function () { if (!e.support()) for (var a = t.document.getElementsByTagName("link"), n = 0; n < a.length; n++) { var o = a[n]; "preload" !== o.rel || "style" !== o.getAttribute("as") || o.getAttribute("data-loadcss") || (o.setAttribute("data-loadcss", !0), e.bindMediaToggle(o)) } }, !e.support()) { e.poly(); var a = t.setInterval(e.poly, 500); t.addEventListener ? t.addEventListener("load", function () { e.poly(), t.clearInterval(a) }) : t.attachEvent && t.attachEvent("onload", function () { e.poly(), t.clearInterval(a) }) } "undefined" != typeof exports ? exports.loadCSS = loadCSS : t.loadCSS = loadCSS }("undefined" != typeof global ? global : this);

})();</script>
        <script data-publisher-id="3276" data-timeout="1000">if (window.tegna.supportsJavascript) {
    !function (a9, a, p, s, t, A, g) {
        if (a[a9]) return; function q(c, r) { a[a9]._Q.push([c, r]) } a[a9] = {
            init: function () { q("i", arguments) }, fetchBids: function () { q("f", arguments) }, setDisplayBids: function () { }, _Q: []
        }; A = p.createElement(s); A.async = !0; A.src = t; g = p.getElementsByTagName(s)[0]; g.parentNode.insertBefore(
            A, g)
    }("apstag", window, document, "script", "//c.amazon-adsystem.com/aax2/apstag.js");

    window.apstag.init({
        'pubID': document.currentScript.dataset.publisherId,
        'adServer': 'googletag',
        'videoAdServer': 'DFP',
        'bidTimeout': document.currentScript.dataset.timeout
    });
}</script>
            <script src="//js-sec.indexww.com/ht/p/184603-186202549686371.js" async></script>
            <script>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</script>
<!-- utag_data -->
<script id="utag_data_script" data-page-type="article" data-gpt-network-code="32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet" data-section="entertainment" data-subsection="events" data-topic="what-to-do" data-subtopic="" data-content-type="article" data-category="entertainment" data-market="Buffalo, NY" data-subcategory="events" data-keywords="WGRZ, Buffalo, news, local news, breaking news, traffic, weather, sports, events" data-document-title="Buffalo, NY | Local News, Weather, Traffic, Sports | WGRZ.com" data-ga-property-id="UA-72921723-1" data-division="broadcast" data-site-type="desktop" data-page-url="http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" data-canonical-url="https://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" data-asset-id="33c55a26-ea7a-4ac7-a17f-7722cad687f6" data-article-keywords="what-to-do,entertainment,events" data-content-title="Juneteenth Festival of Buffalo -2020" data-content-categories="what-to-do,entertainment,events" data-content-score="32" data-tracking-tags="" data-t1-publisher="Colleen Carroll-Nossavage" data-call-letters="WGRZ" data-article-byline="Colleen Nossavage" data-topics-included="false" data-video-included="true" data-video-autoplay="true" data-item-number="1" data-original-headline="Juneteenth Festival of Buffalo -2020" data-cct-story="false" data-platform="desktop">(function () {
    if (window.tegna.supportsJavascript) {
        var data = document.getElementById('utag_data_script').dataset;
        window.utag_data = {
            'template_type': "", // ux name for page layout
            'page_type': data.pageType,
            'division': data.division,
            'site_type': data.siteType,
            'page_url': data.pageUrl,
            'gpt_network_code': data.gptNetworkCode,
            'section': data.section,
            'subsection': data.subsection,
            'topic': data.topic,
            'subtopic': data.subtopic,
            'content_type': data.contentType,
            'category': data.category,
            'market': data.market,
            'subcategory': data.subcategory,
            'keywords': data.keywords,
            'document_title': data.documentTitle,
            'ga_property_id': data.gaPropertyId,
            'canonical_url': data.canonicalUrl,
            'video_included': data.videoIncluded,
            'article_date': data.articleDate,
            'asset_id': data.assetId,
            'article_keywords': data.articleKeywords,
            'content_title': data.contentTitle,
            'original_headline': data.originalHeadline,
            'content_categories': data.contentCategories,
            'tracking_tags': data.trackingTags,
            't1_publisher': data.t1Publisher,
            'article_byline': data.articleByline,
            'topics_included': data.topicsIncluded,
            'call_letters': data.callLetters,
            'item_number': data.itemNumber,
            'content_score': data.contentScore,
            'cct_story': data.cctStory,
            'platform': data.platform
        };
    }
})();</script>            <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">
            var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
                console.log('recaptcha is ready');
            }
        </script>
    <style>
        .root_ie_true template {
            display: none;
        }
    </style>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <script>if (window.tegna.supportsJavascript) {
    window.tegna.log = function (source, action, data, severity) {
        var sourcePadding = 20 - source.length;
        sourcePadding = sourcePadding < 0 ? 0 : sourcePadding;

        var actionPadding = 30 - action.length;
        actionPadding = actionPadding < 0 ? 0 : actionPadding;

        var type = 'log';
        if ('error' in console && severity === 3) {
            type = 'error';
        } else if ('warn' in console && severity === 2) {
            type = 'warn';
        } else if ('info' in console) {
            type = 'info';
        }

        var message = '[' + source + '] ' + ' '.repeat(sourcePadding) + action + ' '.repeat(actionPadding);

        if (data) {
            void 0;
        } else {
            void 0;
        }
    };
    window.tegna.loadModule = function (script, name) {
        var container = script.parentNode;
        var template = container.querySelectorAll(".grid__template")[0];
        if (typeof templatePolyfill !== 'undefined') {
            templatePolyfill(container);
        }
        var clone = document.importNode(template.content, true);
        var observer;
        var intersectionObserverIsSupported = 'IntersectionObserver' in window && 'IntersectionObserverEntry' in window;
        script.remove();
        if (intersectionObserverIsSupported) {
            observer = new window.IntersectionObserver(function (entries, observer) {
                entries.forEach(function (entry) {
                    if (entry.isIntersecting) {
                        template.remove();
                        container.append(clone);
                        container.closest('.grid__module').classList.add('grid__module_loaded_true');
                        observer.unobserve(container);
                        if (typeof require !== 'undefined') {
                            require([name]);
                        }
                        //window.tegna.lazyload(container);
                        if ('$' in window) {
                            $(window).trigger('tegnaBroadcast', ['grid', 'addedSection', { '$el': $(container) }]);
                            tegna.log('grid', 'addedSection', {
                                '$el': $(container)
                            });
                        }
                    }
                });
            });
            observer.observe(container);
        } else {
            template.remove();
            container.append(clone);
        }
    };
}</script>
    <div data-module="page" class="page" data-platform="desktop" data-environment="Production" data-is-monitor="false" data-is-preview="false" data-site-id="71" data-primarydomain="wgrz.com" data-call-letters="WGRZ" data-twitter-id="WGRZ" data-fban="214344422473170" data-refresh="420" data-dfpid="32805352" data-comscoreid="19962895" data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah" data-targeting-video_included="True" data-targeting-ttid="33c55a26-ea7a-4ac7-a17f-7722cad687f6" data-targeting-pgtype="article" data-targeting-topic_section="" data-targeting-url="http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" data-gptid="NY-Buffalo-WGRZ-B3315_DesktopTablet" data-tealium-url="//tags.tiqcdn.com/utag/tegna/wgrz-redesign-desktop/prod/utag" data-tealium-id-chartbeat="2" data-tealium-id-comscore="1" data-tealium-id-datasphere="449" data-tealium-id-dealboss="554" data-tealium-id-googleanalytics="489" data-tealium-id-simplifi="557" data-tealium-id-taboola="556" data-tealium-id-truanthem="442" data-tealium-id-visto="448" >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
        <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_universal/entertainment/events/what-to-do"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-position="article_universal"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
                    <div class="page__header">
<header data-module="header" class="header"
        data-alerts="true"
        data-facebook-app-id="214344422473170"
        data-twitter-id="WGRZ">
    <a class="header__skip" href="#main">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="Home" src="/assets/shared-images/logos/wgrz.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link" href="/news" target="_self" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Local</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Entertainment</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Health</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Money</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Nation World</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Politics</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/investigations" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">2 Investigates</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/verify" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">VERIFY</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/shows" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Shows</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Features</span>
                                                    </a>
                                                </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/video/entertainment/television/programs/most-buffalo/cash-for-robocalls/71-af02f17d-8689-48d2-8563-b4f48caf036e" aria-label="Read Cash for robocalls">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/f33b4c4b-0f51-46e7-a81b-c1aa57e78764/f33b4c4b-0f51-46e7-a81b-c1aa57e78764_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/video/entertainment/television/programs/most-buffalo/cash-for-robocalls/71-af02f17d-8689-48d2-8563-b4f48caf036e">Cash for robocalls</a></h4>
            </div>
        </li>
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/news/health/coronavirus/niagara-county-announces-5-new-covid-19-related-deaths-22-new-cases-of-covid-19/71-79095c66-4894-40bd-bc57-7ec65fd65902" aria-label="Read Erie County hospitalizations drops, Niagara County reports 15 new cases of COVID-19">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_16x9.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_360x203.png" data-srcset="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_16x9.png 16w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_140x79.png 140w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_360x203.png 360w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_540x304.png 540w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_750x422.png 750w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_1140x641.png 1140w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_1920x1080.png 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/health/coronavirus/niagara-county-announces-5-new-covid-19-related-deaths-22-new-cases-of-covid-19/71-79095c66-4894-40bd-bc57-7ec65fd65902">Erie County hospitalizations drops, Niagara County reports 15 new cases of COVID-19</a></h4>
            </div>
        </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link" href="/weather/" target="_self" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Forecast</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Radar</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">10-Day/Hourly</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/closings" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Closings &amp; Delays</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Traffic</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/weather-cameras" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Weather Cameras</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/climate" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Climate Minute</span>
                                                    </a>
                                                </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/weather/forecast/storm-team-2-forecast-western-new-york/71-5b01cf84-0b90-4cad-a4ad-73a029c73fce" aria-label="Read Storm Team 2 Forecast">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/d8c28796-3d4c-436a-b15b-7510997948ff/d8c28796-3d4c-436a-b15b-7510997948ff_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/weather/forecast/storm-team-2-forecast-western-new-york/71-5b01cf84-0b90-4cad-a4ad-73a029c73fce">Storm Team 2 Forecast</a></h4>
            </div>
        </li>
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="https://www.wgrz.com/article/about-us/storm-team-2-doppler-radar/71-38f167c5-3dc7-469c-a555-7c1ebe26661e" aria-label="Read Storm Team 2 Doppler Radar">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c/1e7e40ad-dab7-4b41-b6aa-adfc45fb0f2c_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.wgrz.com/article/about-us/storm-team-2-doppler-radar/71-38f167c5-3dc7-469c-a555-7c1ebe26661e">Storm Team 2 Doppler Radar</a></h4>
            </div>
        </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link" href="/sports" target="_self" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                        <span class="header__nav-label">Sports</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/bills" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Bills</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/sabres" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Sabres</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/bisons" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Bisons</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/ub-bulls" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">UB Bulls</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/hss" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">High School Sports</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/hss/dick-gallagher" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Dick Gallagher&#x27;s HS Football</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/tee2green" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Tee 2 Green</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/nascar" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">NASCAR</span>
                                                    </a>
                                                </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Sports Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/sports/nfl/bills/culture-has-become-a-big-selling-point-to-prospective-buffalo-bills-players/71-4ca7d19a-5f1c-42cc-acb3-f9ee2ef709de" aria-label="Read Culture has become a big selling point to prospective Buffalo Bills players">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97/1a0cf4b9-b98c-4ef0-865f-cca8fd95bc97_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/sports/nfl/bills/culture-has-become-a-big-selling-point-to-prospective-buffalo-bills-players/71-4ca7d19a-5f1c-42cc-acb3-f9ee2ef709de">Culture has become a big selling point to prospective Buffalo Bills players</a></h4>
            </div>
        </li>
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/news/nation-world/nfl-onside-kick-alternative-rule/507-a8246b08-207f-45d5-b3d4-dabd165223dc" aria-label="Read No more onside kicks? NFL to look at &#x27;4th and 15&#x27; alternative">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_360x203.jpg" data-srcset="https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_16x9.jpg 16w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_140x79.jpg 140w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_360x203.jpg 360w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_540x304.jpg 540w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_750x422.jpg 750w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_1140x641.jpg 1140w, https://media.wgrz.com/assets/CCT/images/4aa76bed-7ead-4cce-8712-d90a1c2e74b3/4aa76bed-7ead-4cce-8712-d90a1c2e74b3_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/nation-world/nfl-onside-kick-alternative-rule/507-a8246b08-207f-45d5-b3d4-dabd165223dc">No more onside kicks? NFL to look at &#x27;4th and 15&#x27; alternative</a></h4>
            </div>
        </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link" href="/connect" target="_self" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                        <span class="header__nav-label">Connect</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/about-us" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">About Us</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/advertise" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Advertise</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/contact-us" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Contact Us</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="https://www.jobs.net/jobs/tegna/en-us/all-jobs/?companyf=WGRZ" target="_blank" rel="noopener" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Jobs</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/meet-the-team" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Meet the Team</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/tv-listings" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">TV Listings</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/email" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">Sign Up For Newsletters</span>
                                                    </a>
                                                </li>
                                                <li class="header__subnav-item header__subnav-item_type_text">
                                                    <a class="header__subnav-link header__subnav-link_type_text" href="/" target="_self" rel="" data-tracking-action="navigation/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                                                                <span class="header__subnav-label">#BeOn2</span>
                                                    </a>
                                                </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/news/health/coronavirus/study-casts-more-doubt-on-hydroxychloroquine-for-coronavirus/507-69b2a7bf-8016-4f20-af5f-192c18d68e74" aria-label="Read Large study casts more doubt on malaria drugs for coronavirus">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_360x203.jpg" data-srcset="https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_16x9.jpg 16w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_140x79.jpg 140w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_360x203.jpg 360w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_540x304.jpg 540w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_750x422.jpg 750w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_1140x641.jpg 1140w, https://media.wgrz.com/assets/CCT/images/d4d795d8-75c5-4bec-94c0-49dbc2c96fec/d4d795d8-75c5-4bec-94c0-49dbc2c96fec_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/health/coronavirus/study-casts-more-doubt-on-hydroxychloroquine-for-coronavirus/507-69b2a7bf-8016-4f20-af5f-192c18d68e74">Large study casts more doubt on malaria drugs for coronavirus</a></h4>
            </div>
        </li>
        <li class="story-row__item story-row__item_size_half">
            <div class="story-row__photo">
                <div class="story-row__ratio-enforcer">
                    <div class="story-row__ratio-enforced">
                        <a class="story-row__image-link" href="/article/news/health/coronavirus/niagara-county-announces-5-new-covid-19-related-deaths-22-new-cases-of-covid-19/71-79095c66-4894-40bd-bc57-7ec65fd65902" aria-label="Read Erie County hospitalizations drops, Niagara County reports 15 new cases of COVID-19">
                            <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_16x9.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_360x203.png" data-srcset="https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_16x9.png 16w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_140x79.png 140w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_360x203.png 360w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_540x304.png 540w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_750x422.png 750w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_1140x641.png 1140w, https://media.wgrz.com/assets/WGRZ/images/2e4ff5ef-d516-4395-ad5d-767a1fb932b9/2e4ff5ef-d516-4395-ad5d-767a1fb932b9_1920x1080.png 1920w" sizes="calc(50vw - 15px)" /></div>
                        </a>
                    </div>
                </div>
            </div>
            <div class="story-row__text">
                <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="/article/news/health/coronavirus/niagara-county-announces-5-new-covid-19-related-deaths-22-new-cases-of-covid-19/71-79095c66-4894-40bd-bc57-7ec65fd65902">Erie County hospitalizations drops, Niagara County reports 15 new cases of COVID-19</a></h4>
            </div>
        </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                                        <li>
                        <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_false">
    <a class="watch-live__cta">
        <span class="watch-live__label">Watch Live</span>
    </a>
    <div class="watch-live__mini-live-video">
    <div data-module="mini-live-video" class="mini-live-video">
        <div class="mini-live-video__controls">
            <div class="mini-live-video__button mini-live-video__button_type_pause"></div>
            <div class="mini-live-video__button mini-live-video__button_type_unmute"></div>
            <a class="mini-live-video__button mini-live-video__button_type_open" aria-label="View larger"></a>
        </div>
        <div class="mini-live-video__player"></div>
    </div>    </div>
</div>                        </div>
                    </li>
                    <li class="header__nav-item header__nav-item_type_search">
                        <span class="header__nav-link header__nav-link_type_search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </span>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search wgrz.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
        <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/masthead_sponsor/entertainment/events/what-to-do"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-position="masthead_sponsor"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_true">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_true">Buffalo, NY &nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_true">
                                <div class="header__weather-temp header__weather-temp_alerts_true">71&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_true">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-65_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-65_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-65_8x8.png 8w, /assets/shared-images/weather-icons/wx-65_16x16.png 16w, /assets/shared-images/weather-icons/wx-65_32x32.png 32w, /assets/shared-images/weather-icons/wx-65_64x64.png 64w, /assets/shared-images/weather-icons/wx-65_128x128.png 128w, /assets/shared-images/weather-icons/wx-65_210x210.png 210w" sizes="26px" /><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-65_32x32.png" srcset="/assets/shared-images/weather-icons/wx-65_8x8.png 8w, /assets/shared-images/weather-icons/wx-65_16x16.png 16w, /assets/shared-images/weather-icons/wx-65_32x32.png 32w, /assets/shared-images/weather-icons/wx-65_64x64.png 64w, /assets/shared-images/weather-icons/wx-65_128x128.png 128w, /assets/shared-images/weather-icons/wx-65_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_true">Buffalo, NY &nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_false" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">Weather</a>
                                    <a class="header__alert header__alert_type_closings header__alert_visible_true" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <div class="header__featured-arrow header__featured-arrow_direction_previous"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/coronavirus-covid-19">Coronavirus</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/vote">VOTE</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/mostbuffalo">Most Buffalo</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/dioceseincrisis">Diocese in Crisis</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/albany">Holding Albany Accountable</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/investigativeposts">Investigative Post</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/takeout">Takeout Map</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/unknown-stories">Unknown Stories of WNY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/email">Sign up for newsletter</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/cityshapers">City Shapers</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/verify">VERIFY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/closings">Closings</a>
                        </li>
                </ul>
            </div>
            <div class="header__featured-arrow header__featured-arrow_direction_next"><img src="/images/header/arrow.png" width="14" height="14" loading="eager" alt="" /></div>
    </div>
</header>                <div class="page__dock"></div>
            </div>
        <main class="page__main" id="main">
                    <div class="page__breaking-news-alerts">
                    </div>
            <div class="page__grid">
                


    <div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section">
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                            <h1 class="grid__page-heading_visible_false">Buffalo, NY | Local News, Weather, Traffic, Sports | WGRZ.com</h1>
                                                                <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="33c55a26-ea7a-4ac7-a17f-7722cad687f6"
         data-title="Juneteenth Festival of Buffalo -2020"
         data-seo-title="Juneteenth Festival of Buffalo -2020"
         data-abstract="On-line Virtual Celebration, June 13th &amp; 14th"
         data-section="entertainment"
         data-subsection="events"
         data-topic="what-to-do"
         data-subtopic=""
         data-url="www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6"
         data-gpt-network-code="32805352"
         data-categories="what-to-do, entertainment, events"
         data-author="Colleen Nossavage"
         data-keywords="[&#xD;&#xA;  &quot;what-to-do&quot;,&#xD;&#xA;  &quot;entertainment&quot;,&#xD;&#xA;  &quot;events&quot;&#xD;&#xA;]"
         data-has-video="true"
         data-t1-publisher="Colleen Carroll-Nossavage">
    <a class="article__category" href="/section/what-to-do">what-to-do</a>
    <h1 class="article__headline">Juneteenth Festival of Buffalo -2020</h1>
    <div class="article__summary">On-line Virtual Celebration, June 13th & 14th</div>
    <div class="article__lead-asset">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="750" height="422" src="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="750" height="422" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_1920x1080.jpg 1920w" sizes="750px" /><noscript><img class="lazy-image__nojs-image" alt="" width="750" height="422" src="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_750x422.jpg" srcset="https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/1b8de418-5b7d-4cca-bf0d-f1aa29022d09/1b8de418-5b7d-4cca-bf0d-f1aa29022d09_1920x1080.jpg 1920w" sizes="750px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
            <div class="photo__credit">Credit: Juneteenth of Buffalo</div>
            </div>
</div>    </div>
    <aside class="article__meta">
            <div class="article__author">
                <span class="article__meta-label">Author:</span> Colleen Nossavage
            </div>
                    <div class="article__published">
                <span class="article__meta-label">Published:</span> 12:48 PM EDT May 22, 2020
            </div>
                    <div class="article__updated">
                <span class="article__meta-label">Updated:</span> 12:48 PM EDT May 22, 2020
            </div>
            <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=214344422473170&display=popup&href=http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6&redirect_uri=http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=Juneteenth%20Festival%20of%20Buffalo%20-2020&url=http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6&via=WGRZ" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="link click" data-tracking-label="Link From: http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>    </aside>
    <div class="article__body">
                            <div class="article__section article__section_type_text">
<p>BUFFALO, N.Y. — This year celebrates the 45th consecutive Juneteenth Festival of Buffalo and the tradition will continue with Juneteenth festivities taking place on-line through social media on June 13th &amp; 14th. &nbsp;</p>                                            </div>
                    <div class="article__section article__section_type_text">
<p>Due to restrictions with COVID-19 and a dedication to the safety of the WNY community the Board of Directors of Juneteenth of Buffalo announced that instead of the people coming to Martin Luther King Jr Park for Juneteenth Festival the Juneteenth Festival will come to the people through a virtual on-line celebration through social media.&nbsp;</p>                                            </div>
                        <div class="article__section article__section_type_ad">
        <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid1/entertainment/events/what-to-do"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-position="article_mid1"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text">
<p>Throughout the weekend of June 13th -14th information and video presentations on enrichment, education and community spirit will be posted on <a href="http://www.juneteenthofbuffalo.com/" rel="noopener noreferrer" target="_blank">JuneteenthofBuffalo.com</a> and on the <a href="https://www.facebook.com/BuffaloJuneteenth" rel="noopener noreferrer" target="_blank">Juneteenth of Buffalo</a> facebook page.&nbsp;</p>                                            </div>
                    <div class="article__section article__section_type_text">
<p>Check out footage and WGRZ photo gallery from the 2019 Juneteenth Festival of Buffalo. Please share your favorite photos and memories of past Juneteenth Festivals with WGRZ using the #BeOn2. &nbsp;</p>                                            </div>
                                <div class="article__section article__section_type_video">
    <div data-module="video" class="video"
         data-stream="https://video.wgrz.com/assets/WGRZ/videos/2f14de9c-0881-4936-a1e2-88a1b1dde222/20190615T215503.m3u8"
         data-float="false"
         data-thumbnail="https://media.wgrz.com/assets/WGRZ/images/e3fe2309-5430-4947-bba9-966c42bba669/e3fe2309-5430-4947-bba9-966c42bba669_1920x1080.jpg"
         data-title="Buffalo Celebrates 44th Juneteenth Festival"
         data-description="44 years of the Juneteenth festival celebrating African American Culture in Buffalo. Today&#x27;s Festival kicked off with a parade down Genesee St. The streets lined with people of all ages watching."
         data-site="71"
         data-id="2f14de9c-0881-4936-a1e2-88a1b1dde222"
         data-dfpposition=""
         data-mute="false"
         data-autoplay="false"
         data-link="https://www.wgrz.com/video/news/buffalo-celebrates-44th-juneteenth-festival/71-2f14de9c-0881-4936-a1e2-88a1b1dde222"
         data-origin="clipping"
         data-section="news"
         data-subsection=""
         data-topic=""
         data-subtopic=""
         data-related-playlist-id="qrW9G1iZ"
         data-related-media-id="hw30Ako8"
         data-use-trending="true">
        <div class="video__ratio-enforcer">
            <div class="video__ratio-enforced">
                <div class="video__inner">
                    <div class="video__teaser video__teaser_visible_true">
                        <img class="video__thumbnail" data-asset-fallback="default" src="https://media.wgrz.com/assets/WGRZ/images/e3fe2309-5430-4947-bba9-966c42bba669/e3fe2309-5430-4947-bba9-966c42bba669_1920x1080.jpg" />
                        <div class="video__error"></div>
                        <div class="video__button video__button_play"></div>
                    </div>
                    <div class="video__player-container">
                        <div class="video__player"></div>
                    </div>
                </div>
            </div>
        </div>
                            <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Buffalo Celebrates 44th Juneteenth Festival",
                    "description": "44 years of the Juneteenth festival celebrating African American Culture in Buffalo. Today&#x27;s Festival kicked off with a parade down Genesee St. The streets lined with people of all ages watching.",
                    "thumbnailUrl": "https://media.wgrz.com/assets/WGRZ/images/e3fe2309-5430-4947-bba9-966c42bba669/e3fe2309-5430-4947-bba9-966c42bba669_1920x1080.jpg",
                    "uploadDate": "6/16/2019 12:27:56 AM",
                    "duration": "88",
                    "contentUrl": "https://www.wgrz.com/video/news/buffalo-celebrates-44th-juneteenth-festival/71-2f14de9c-0881-4936-a1e2-88a1b1dde222",
                    "embedUrl": "https://media.wgrz.com/embeds/video/2f14de9c-0881-4936-a1e2-88a1b1dde222/iframe"
                    }
                </script>
        </div>
                                </div>
                                <div class="article__section article__section_type_gallery">
<div data-module="gallery" class="gallery" data-initial-slide="0">
    <h4 class="gallery__title">PHOTOS: Scenes from Buffalo&#x27;s 44th annual Juneteenth parade and festival</h4>
    <div class="gallery__outer-ratio-enforcer">
        <div class="gallery__outer-ratio-enforced">
            <div class="gallery__initial-image">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_1920x1080.jpg 1920w" sizes="1140px" /></div>
            </div>
            <div class="gallery__slider">
                <ul class="gallery__slides">
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="4a1c4ed3-72bb-49bc-b94a-f4c78829daf4">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4/4a1c4ed3-72bb-49bc-b94a-f4c78829daf4_1920x1080.jpg 1920w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">1/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="dd9a0211-5ece-4c10-acf6-5f9eb3a169df">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/dd9a0211-5ece-4c10-acf6-5f9eb3a169df/dd9a0211-5ece-4c10-acf6-5f9eb3a169df_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">2/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="4d325419-e9cb-46aa-834f-669ec0c2cb47">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/4d325419-e9cb-46aa-834f-669ec0c2cb47/4d325419-e9cb-46aa-834f-669ec0c2cb47_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">3/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="61fac633-8026-4c52-9855-397e0761f17e">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/61fac633-8026-4c52-9855-397e0761f17e/61fac633-8026-4c52-9855-397e0761f17e_1920x1080.jpg 1920w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">4/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="acb0ecbf-0f5b-4231-9c74-d287a344d30b">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/acb0ecbf-0f5b-4231-9c74-d287a344d30b/acb0ecbf-0f5b-4231-9c74-d287a344d30b_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">5/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="cc1cc594-4731-45e8-a601-3968457fbd8b">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/cc1cc594-4731-45e8-a601-3968457fbd8b/cc1cc594-4731-45e8-a601-3968457fbd8b_1920x1080.jpg 1920w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">6/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6/e9cdcbdf-593c-43f3-ad63-6b1e15dfeee6_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">7/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="2d590410-cdb1-4bad-82a6-c249c2f88c99">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/2d590410-cdb1-4bad-82a6-c249c2f88c99/2d590410-cdb1-4bad-82a6-c249c2f88c99_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">8/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="bf19eb81-9d3e-4946-85be-0c8e59dc07e1">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/bf19eb81-9d3e-4946-85be-0c8e59dc07e1/bf19eb81-9d3e-4946-85be-0c8e59dc07e1_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">9/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="98ebb342-8751-41fe-9af7-4db9f902ddc0">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/98ebb342-8751-41fe-9af7-4db9f902ddc0/98ebb342-8751-41fe-9af7-4db9f902ddc0_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">10/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="bc03938a-2f64-4894-9421-1246c891c86c">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/bc03938a-2f64-4894-9421-1246c891c86c/bc03938a-2f64-4894-9421-1246c891c86c_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">11/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="a5e65a4d-86bf-4975-9ef5-fc807c404031">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/a5e65a4d-86bf-4975-9ef5-fc807c404031/a5e65a4d-86bf-4975-9ef5-fc807c404031_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">12/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="6b85b35a-2522-43ed-818f-b7274aaac87e">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/6b85b35a-2522-43ed-818f-b7274aaac87e/6b85b35a-2522-43ed-818f-b7274aaac87e_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">13/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                        <li class="gallery__slide" data-credit="Karys Belger" data-caption="" id="5bc3c494-d9cf-4174-8eca-1a6105bb6392">
                            <div class="gallery__ratio-enforcer">
                                <div class="gallery__ratio-enforced">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_140x79.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_140x79.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_750x422.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_1920x1080.jpg 1920w, https://media.wgrz.com/assets/WGRZ/images/5bc3c494-d9cf-4174-8eca-1a6105bb6392/5bc3c494-d9cf-4174-8eca-1a6105bb6392_1140x641.jpg 1140w" sizes="1140px" /></div>
                                    <noscript>
                                        <div class="gallery__nojs-count">14/14</div>
                                    </noscript>
                                </div>
                            </div>
                            <noscript>
                                <div class="gallery__nojs-meta">
                                    <div class="gallery__nojs-credit">Karys Belger</div>
                                    <div class="gallery__nojs-description"></div>
                                </div>
                            </noscript>
                        </li>
                </ul>
                <div class="gallery__controls">
                    <button class="gallery__arrow gallery__arrow_type_previous"></button>
                    <button class="gallery__arrow gallery__arrow_type_next"></button>
                </div>
                <div class="gallery__count">
                    <span class="gallery__current-slide-number">1</span>
                    <span class="gallery__count-separator">/</span>
                    <span class="gallery__total-slide-count">14</span>
                </div>
            </div>
        </div>
    </div>
    <div class="gallery__meta">
        <button class="gallery__close">×</button>
        <div class="gallery__credit">Karys Belger</div>
        <div class="gallery__description">
            <div class="gallery__description-text">
                <span class="gallery__description-text-inner"></span> <button class="gallery__more">More</button>
            </div>
        </div>
    </div>
</div>
                                </div>
                    <div class="article__section article__section_type_text">
<p>The tradition and mission of Juneteenth of Buffalo will continue. Juneteenth of Buffalo, Inc. exists exclusively for charitable and educational purposes. Staffed by volunteers, its mission is to actively preserveand promote the broad spectrum of African American heritage through educational and cultural activities that will benefit the community as a whole. &nbsp;</p>                                            </div>
                    <div class="article__section article__section_type_text">
<p>WGRZ Ch. 2 is a sponsor of Juneteenth of Buffalo.&nbsp;</p>                                            </div>
    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "Juneteenth Festival of Buffalo -2020",
  "datePublished": "12:48 PM EDT May 22, 2020",
  "dateModified": "12:48 PM EDT May 22, 2020",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "http://www.wgrz.com/article/entertainment/events/what-to-do/juneteenth2020/71-33c55a26-ea7a-4ac7-a17f-7722cad687f6"
  },
  "author": {
    "@type": "Person",
    "name": "Colleen Nossavage"
  },
  "publisher": {
    "@type": "Organization",
    "name": "WGRZ",
    "logo": {
      "@type": "ImageObject",
      "url": "http://www.wgrz.com/assets/shared-images/amp-logos/wgrz.png",
      "width": 340,
      "height": 60
    }
  },
  "image": null
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="http://www.wgrz.com::contentUrl::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_atf/entertainment/events/what-to-do"
         data-sizes="[[300,250],[300,600]]"
         data-delay="8"
         data-position="article_atf"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_atf/entertainment/events/what-to-do&amp;sz=300x250|300x600&amp;c=768" width="300" height="600" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section">
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                                                                <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
        <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_flex_btf/entertainment/events/what-to-do"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-position="article_flex_btf"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_flex_btf/entertainment/events/what-to-do&amp;sz=970x250|728x90|1140x286|1x1&amp;c=768" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section">
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                                                                <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true">
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
    </div>

            </div>
        </main>
            <div class="page__footer">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="WGRZ-TV" src="/assets/shared-images/logos/wgrz.png">
            </div>
            <div class="footer__menu">
                        <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://www.jobs.net/jobs/tegna/en-us/all-jobs/?companyf=WGRZ" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                        </ul>
                        <ul class="footer__list">
                                <li class="footer__item"><a class="footer__link" href="https://interactive.wgrz.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item"><a class="footer__link" href="/do-not-sell-my-information" target="_self" rel="">Do Not Sell My Information</a></li>
                        </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2020 WGRZ-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
        <div data-module="ad" class="ad ad_position_exit_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/exit_interstitial/entertainment/events/what-to-do"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-position="exit_interstitial"
         data-a9-enabled="true"
         data-targeting-strnativekey="">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
            <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="WGRZ" src="/assets/shared-images/logos/wgrz.png" />
    </div>
    <h2 class="notifications__heading">WGRZ would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/Content/logos/dark/wgrz.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
    <script data-key="pNHOjJyj2m9zXrCu&#x2B;E8emJVKczLfYeNWPKDJjw==">(function () {
    window.jwplayer = window.jwplayer || {};
    window.jwplayer.key = window.jwplayer.key || document.currentScript.dataset.key;
})();</script>
    <script>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</script>
    <script data-base="/" data-modules="ad,adchoices,all-alerts,article,article-loader,article-sharing,breaking-news-alerts,breaking-news-list,carousel,chapter-slider,closings,countdown,datasphere,datasphere-ad-article,datasphere-ad-front,elections,error,footer,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,lazy-image,live-video-banner,longform,mini-live-video,newsletter-signup,notifications,page,personal-info,photo,pollen,privacy,radar-gallery,raw-html,related-stories,right-now-hourly,right-now-radar,search,story,story-list,story-row,taboola,toasts,tos,universal-ad,video,watch-live,weather-10-day,weather-alerts-list,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="4.5.19">(function () {
    if (window.tegna.supportsJavascript) {
        var allModules = document.currentScript.dataset.modules.split(',');
        allModules.push('jquery', 'utils', 'storage', 'tegna-tracking', 'header-updater');
        var modulesOnPage = ['ad', 'gallery', 'video', 'taboola', 'related-stories', 'raw-html', 'photo', 'lazy-image', 'elections'];

        function inArray(needle, haystack) {
            var count = haystack.length;
            for (var i = 0; i < count; i++) {
                if (haystack[i] === needle) { return true; }
            }
            return false;
        }

        var moduleElements = document.querySelectorAll('[data-module]');
        for (var i = 0; i < moduleElements.length; ++i) {
            (function () {
                var thisModuleName = moduleElements[i].getAttribute('data-module');
                if (!inArray(thisModuleName, modulesOnPage)) {
                    modulesOnPage.push(thisModuleName);
                }
            })();
        }

        var buildVersion = document.currentScript.dataset.version;
        var baseUrl = document.currentScript.dataset.base;

        require.config({
            'baseUrl': baseUrl,
            'deps': modulesOnPage,
            'waitSeconds': 30,
            'bundles': {
                'modules': allModules
            },
            'paths': {
                'modules': 'modules.min.js?ver=' + buildVersion,
                'swiper': 'assets/js-libs/swiper/swiper.min.js?ver=' + buildVersion,
                'live-messages': 'assets/js-libs/live-messages/live-messages.js?ver=' + buildVersion,
                'luxon': 'assets/js-libs/luxon/luxon.min.js?ver=' + buildVersion,
                'tealium': document.getElementsByClassName('page')[0].dataset.tealiumUrl,
                'signalr': 'assets/js-libs/signalr/signalr.min.js?ver=' + buildVersion,
                'jwplayer': 'assets/js-libs/jwplayer/jwplayer.js?ver=' + buildVersion,
                'comscore': 'assets/js-libs/comscore/comscore.min.js?ver=' + buildVersion,
                '@firebase/app': 'https://www.gstatic.com/firebasejs/6.1.1/firebase-app',
                '@firebase/messaging': 'https://www.gstatic.com/firebasejs/6.1.1/firebase-messaging'
            },
            'shim': {
                'swiper': {
                    'exports': 'Swiper'
                },
                'signalr': {
                    'exports': 'signalR'
                },
                'tealium': ['jquery'],
                'jwplayer': ['jquery']
            }
        });
    }
})();
</script>
        <script data-api-key="AIzaSyCAchbl8p6QgqYvQfGmX_mEVnLm-JtVM5I" data-project-id="wgrz-news-app" data-sender-id="471404531395" data-app-id="1:471404531395:web:16d9c927639acb0d">(function () {
    if (window.tegna.supportsJavascript) {
        var data = document.currentScript.dataset;
        var apiKey = data.apiKey;
        var projectId = data.projectId;
        var senderId = data.senderId;
        var appId = data.appid;
        require([
            '@firebase/app',
            '@firebase/messaging'
        ], function (firebase) {
            firebase.initializeApp({
                apiKey: apiKey,
                authDomain: `${projectId}.firebaseapp.com`,
                databaseURL: `https://${projectId}.firebaseio.com`,
                projectId: projectId,
                storageBucket: `${projectId}.appspot.com`,
                messagingSenderId: senderId,
                appId: appId
            });
            window.firebase = firebase;
        });
    }
})();</script>
    <script>(function () {
    if (!window.tegna.supportsJavascript) {
        function htmlDecode(input) {
            var e = document.createElement('textarea');
            e.innerHTML = input;
            // handle case of empty input
            return e.childNodes.length === 0 ? "" : e.childNodes[0].nodeValue;
        }

        var parent = document.body;
        var notification = document.createElement('div');
        notification.innerHTML = '<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>';
        parent.insertBefore(notification, parent.firstChild);
        //window.setInterval(function () {
            /*
            var images = document.getElementsByClassName('lazy-image__image');
            for (var i = 0; i < images.length; i++) {
                var image = images.item(i);
                if (image.getAttribute('data-src')) {
                    image.setAttribute('src', image.getAttribute('data-src'));
                    image.setAttribute('style', 'display:block;filter:none;opacity:1;');
                    image.classList.remove('lazy-image__image_blur_true');
                    image.removeAttribute('data-src');
                }
            }
            */

        function simulateNoScript() {
            void 0;
            var noscripts = document.getElementsByTagName('noscript');
            for (var i = 0; i < noscripts.length; i++) {
                var noscript = noscripts.item(i);
                noscript.outerHTML = htmlDecode(noscript.innerHTML);
            }
        }

        simulateNoScript();

        var interval = window.setInterval(function () {
            if (document.getElementsByTagName('noscript').length) {
                simulateNoScript();
            } else {
                clearInterval(interval);
            }
        }, 500);
    }
})();</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
        <script>
            if (window.tegna.supportsJavascript) {
                var script = document.createElement('script');
                script.src = "https://www.googletagservices.com/tag/js/gpt.js";
                script.async = true;
                script.defer = true;
                var firstScriptTag = document.getElementsByTagName('script')[0];
                firstScriptTag.parentNode.insertBefore(script, firstScriptTag);
            } else {
                var script = document.createElement('script');
                script.src = "https://www.googletagmanager.com/gtag/js?id=UA-72921723-1";
                var firstScriptTag = document.getElementsByTagName('script')[0];
                firstScriptTag.parentNode.insertBefore(script, firstScriptTag);

                window.dataLayer = window.dataLayer || [];
                function gtag(){dataLayer.push(arguments);}
                gtag('js', new Date());
                gtag('config', 'UA-72921723-1');
            }
        </script>
        <script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js" async></script>
</body>
</html>