<!DOCTYPE html>
<html class="root root_js_disabled" lang="en-US" data-version="2.6.11.2" data-platform="desktop">
<head>
    <meta charset="utf-8" />
    <title>A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski | wgrz.com</title>
    <script>window.tegna=window.tegna||{},window.tegna.getCookie=e=>{e=("; "+document.cookie).split(`; ${e}=`);return 2===e.length?e.pop().split(";").shift():null},window.tegna.usprivacy=window.tegna.getCookie("usprivacy"),function(){window.performance.mark("tegna_server_response");var n=new URLSearchParams(window.location.search).get("otConsentString");if(n){document.cookie="OptanonAlertBoxClosed="+(new Date).toISOString();let e=new Date;e.setYear(e.getFullYear()+1),e=e.toISOString();var t=(new Date).toString().replace(/\ /g,"+").replace(/:/g,"%3A");document.cookie=`OptanonConsent=datestamp=${t}&version=6.0.0&interactionCount=0&isIABGlobal=false&landingPath=NotLandingPage&groups=${encodeURIComponent(n)}&hosts=&legInt=; expires=`+e}}(),window.tegna.supportsJavascript="noModule"in document.createElement("script"),window.tegna.supportsJavascript?(document.documentElement.classList.remove("root_js_disabled"),window.tegna.performance={received:{time:window.performance.now()}},window.tegna.ie=!!window.MSInputMethodContext&&!!document.documentMode):document.documentElement.classList.add("root_ie_true");
//# sourceMappingURL=immediate.js.map</script>
    <style>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</style>
    <style>:root {
    --theme-primary: #d81f32;
    --theme-primary-gradient-start: #d81f3246;
    --theme-secondary: #455b6d;
}
</style>

<link rel="preload" href="/modules.min_6.11.2.css" as="style" onload="this.onload=null;this.rel='stylesheet';window.tegna.performance.painted = { 'time': window.performance.now() };window.performance.mark('tegna_styled');" />
<noscript><link rel="stylesheet" href="/modules.min_6.11.2.css"></noscript>

<link rel="preload" href="/common.min_6.11.2.js" as="script" type="text/javascript" />

    <link rel="preconnect" href="//media.wbir.com">
    <link rel="preconnect" href="//interactive.wbir.com">
    <link rel="preconnect" href="//tgna-ux-dev.service.signalr.net">
    <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    <link rel="preconnect" href="//www.google.com">
    <link rel="preconnect" href="//adservice.google.com">
    <link rel="preconnect" href="//tpc.googlesyndication.com">
    <link rel="preconnect" href="//cdn.ampproject.org">
    <link rel="preconnect" href="//pagead2.googlesyndication.com">
    <link rel="preconnect" href="//www.gstatic.com">
    <link rel="icon" href="/assets/favicons/WGRZ.png?ver=2.6.11.2" />
    <link rel="canonical" href="https://www.etonline.com/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski-195514" />
            <meta name="theme-color" content="#d81f32" />
            <link rel="amphtml" href="https://www.wgrz.com/amp/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70" />
        <meta itemprop="datePublished" content="10:24 PM EST December 27, 2022" />
        <meta itemprop="dateModified" content="10:24 PM EST December 27, 2022" />
        <meta itemprop="url" content="https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70" />
        <meta itemprop="magnet:custom" name="category" content="entertainment" />
        <meta property="og:url" content="https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70">
        <meta property="og:title" content="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski">
        <meta property="og:description" content="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski">
        <meta property="og:type" content="article" />
        <meta property="og:image" content="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1140x641.jpg">
        <meta property="og:image:width" content="1140" />
        <meta property="og:image:height" content="641" />
        <meta property="og:article:published_time" content="10:24 PM EST December 27, 2022" />
        <meta property="article:opinion" content="false" />
        <meta property="article:content_tier" content="free">
        <meta property="article:section" content="wgrz,entertainment,entertainment-tonight" />
        <meta name="twitter:title" content="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski">
        <meta name="twitter:image:src" content="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1140x641.jpg">
        <meta name="twitter:image" content="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1140x641.jpg">
        <meta name="twitter:card" content="summary_large_image">
        <meta name="twitter:site" content="WGRZ">
        <meta name="twitter:description" content="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski">
        <meta name="twitter:domain" content="www.wgrz.com/">


            <meta name="viewport" content="width=1170" />
            <meta name="site" content="wgrz.com" />
            <meta name="description" content="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski" />
            <meta property="fb:app_id" content="214344422473170" />
            <meta property="og:site_name" content="wgrz.com" />
            <meta property="og:locale" content="en_US" />
            <meta itemprop="pageType" content="article" />
            <meta itemprop="datePublished" content="10:24 PM EST December 27, 2022" />
    <script>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</script>
        <!-- OneTrust Cookies Consent Notice start -->
        <script src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="b1262fd8-3f56-4a29-958b-6e32ccb1c833"></script>
        <script type="text/javascript">function OptanonWrapper() { }</script>
        <!-- OneTrust Cookies Consent Notice end -->
        <script src="https://cdn.cookielaw.org/opt-out/otCCPAiab.js" type="text/javascript" charset="UTF-8" ccpa-opt-out-ids="C0004,C0002" ccpa-opt-out-geo="all" ccpa-opt-out-lspa="true"></script>
<!-- utag_data -->
<script id="utag_data_script" data-visit-event-name="pageView" data-current-site-id="71" data-watson-keywords="Recap of Pete Davidson,Davidson&#x27;s romances,Davidson&#x27;s magnetic charm,Getty Images,Ariana Grande" data-page-type="article" data-gpt-network-code="32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet" data-section="entertainment" data-subsection="entertainment-tonight" data-topic="" data-subtopic="" data-content-type="article" data-category="entertainment" data-market="Buffalo, NY" data-subcategory="entertainment-tonight" data-keywords="WGRZ, Buffalo, news, local news, breaking news, traffic, weather, sports, events" data-document-title="Buffalo, NY | Local News, Weather, Traffic, Sports | WGRZ.com" data-ga-property-id="UA-72921723-1" data-division="broadcast" data-site-type="desktop" data-page-url="https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70" data-canonical-url="https://www.etonline.com/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski-195514" data-asset-id="5b766038-6f7a-4206-b5d1-7e392b66ee70" data-article-keywords="entertainment,celebrity news,entertainment-tonight" data-content-title="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski" data-content-categories="entertainment,entertainment-tonight" data-content-score="" data-tracking-tags="" data-t1-publisher="" data-call-letters="WGRZ" data-article-byline="Zach Seemayer&#x200D;" data-topics-included="false" data-video-included="false" data-video-autoplay="false" data-video-title="" data-video-name="" data-video-length="0" data-video-related-play="false" data-item-number="1" data-original-headline="A Recap of Pete Davidson&amp;#039;s Romantic History: From Cazzie David to Emily Ratajkowski" data-cct-story="false" data-platform="desktop" data-full-environment="WGRZ" data-index-wrapper-url="//js-sec.indexww.com/ht/p/184603-186202549686371.js" data-a9-publisher-id="3276" data-a9-timeout="1000" data-oneplusx-client-id="tegna" data-oneplusx-debug="false" data-pubmatic-desktop-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3998/pwt.js" data-pubmatic-mobile-url="https://ads.pubmatic.com/AdServer/js/pwt/160138/3999/pwt.js">!function(){var e;window.tegna.supportsJavascript&&(e=document.getElementById("utag_data_script").dataset,window.tegna.initialTracking={visit_event_name:e.visitEventName,current_site_id:e.currentSiteId,watson_keywords:e.watsonKeywords,template_type:"",page_type:e.pageType,division:e.division,site_type:e.siteType,page_url:e.pageUrl,gpt_network_code:e.gptNetworkCode,section:e.section,subsection:e.subsection,topic:e.topic,subtopic:e.subtopic,content_type:e.contentType,category:e.category,market:e.market,subcategory:e.subcategory,keywords:e.keywords,document_title:e.documentTitle,ga_property_id:e.gaPropertyId,canonical_url:e.canonicalUrl,video_included:e.videoIncluded,video_name:e.videoName,video_length:e.videoLength,video_related_play:e.videoRelatedPlay,article_date:e.articleDate,asset_id:e.assetId,article_keywords:e.articleKeywords,content_title:e.contentTitle,original_headline:e.originalHeadline,content_categories:e.contentCategories,tracking_tags:e.trackingTags,t1_publisher:e.t1Publisher,article_byline:e.articleByline,topics_included:e.topicsIncluded,call_letters:e.callLetters,item_number:e.itemNumber,content_score:e.contentScore,cct_story:e.cctStory,platform:e.platform,full_environment:e.fullEnvironment,index_wrapper_url:e.indexWrapperUrl,a9_publisher_id:e.a9PublisherId,a9_timeout:e.a9Timeout,oneplusx_client_id:e.oneplusxClientId,oneplusx_debug:"true"===e.oneplusxDebug.toLowerCase(),pubmatic_desktop_url:e.pubmaticDesktopUrl,pubmatic_mobile_url:e.pubmaticMobileUrl},window.utag_data=JSON.parse(JSON.stringify(window.tegna.initialTracking)))}();
//# sourceMappingURL=utag-data.js.map</script>
        <script src="https://www.google.com/recaptcha/api.js?onload=recaptchaCallback&render=explicit" async defer></script>
        <script type="text/javascript">
    var recaptchaCallback = function () {
                window.grecaptcha = grecaptcha;
            }</script>
    <style>
        .root_ie_true template {
            display: none;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-header {
            position: relative;
        }
        #onetrust-consent-sdk #onetrust-pc-sdk .pc-logo {
            background-image: url('/assets/shared-images/logos/wgrz.png') !important;
        }
    </style>
    <script type="text/javascript" data-taboola-type="article">window._taboola = window._taboola || [];
        let obj = {};
        obj[document.currentScript.dataset.taboolaType] = 'auto';
        _taboola.push(obj);</script>
    <!-- head content below this is dynamically added -->
</head>
<body>
    <input name="__RequestVerificationToken" type="hidden" value="CfDJ8NdZkYIlzHhKhFJF7ZCePx29PQ5y3WV_K4aF9V5ildIu6KIDQzKtdKWYXXjfKiwzbqfq3eqH42MfqG7GNIsSC7q99qPeK50oueGciiinhcXJK6D9aalg1uoJQA_BFZrumeOYq5zUz_zO7XddhevrCsY" />
    <script>if(window.tegna.supportsJavascript){window.tegna.addScript=e=>{var t=document.createElement("script");t.src=e,document.head.appendChild(t)},window.tegna.renameElement=(e,t)=>{var i=document.createElement(t);for(Array.from(e.attributes).forEach(e=>{i.setAttribute(e.nodeName,e.nodeValue)});e.firstChild;)i.appendChild(e.firstChild);return e.parentNode.replaceChild(i,e)},window.tegna.log=function(e,t,i,n){var o=(o=20-e.length)<0?0:o,r=(r=30-t.length)<0?0:r,a="log",n=("error"in console&&3===n?a="error":"warn"in console&&2===n?a="warn":"info"in console&&(a="info"),"["+e+"] "+" ".repeat(o)+t+" ".repeat(r));"production"!==document.getElementsByClassName("page")[0].dataset.environment.toLowerCase()&&(i?console[a](n,i):console[a](n))},window.tegna.loadModule=function(e,i){var n=e.parentNode,o=n.querySelectorAll(".grid__template")[0],r=("undefined"!=typeof templatePolyfill&&templatePolyfill(n),document.importNode(o.content,!0)),t="IntersectionObserver"in window&&"IntersectionObserverEntry"in window;e.remove(),t?new window.IntersectionObserver(function(e,t){e.forEach(function(e){e.isIntersecting&&(o.remove(),n.append(r),n.closest(".grid__module").classList.add("grid__module_loaded_true"),n.closest(".grid__module").classList.remove("grid__module_loaded_false"),t.unobserve(n),"undefined"!=typeof require&&require([i]),e={el:n},"$"in window&&(e.$el=$(n)),window.dispatchEvent(new CustomEvent("tegnaBroadcast",{detail:{source:"grid",action:"addedSection",data:e}})))})}).observe(n):(o.remove(),n.append(r))};class a extends HTMLElement{get os(){return this.getAttribute("os")}set os(e){this.setAttribute("os",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}connectedCallback(){var e=navigator.userAgent||navigator.vendor||window.opera;let t="unknown";/android/i.test(e)&&(t="android"),(t=/iPad|iPhone|iPod/.test(e)&&!window.MSStream?"ios":t)===this.os.toLowerCase()?this.active=!0:this.active=!1}}window.customElements.define("tegna-sniff",a);class b extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}set active(e){e?(this.setAttribute("aria-hidden","false"),this.setAttribute("active","")):(this.setAttribute("aria-hidden","true"),this.removeAttribute("active"))}constructor(){super()}}window.customElements.define("tegna-variant",b);class c extends HTMLElement{get uuid(){return this.getAttribute("uuid")}set uuid(e){this.setAttribute("uuid",e)}constructor(){super()}connectedCallback(){window.setTimeout(()=>{var e=[...this.children];let a=e[0].uuid;var t=window.localStorage.getItem(this.uuid);null!==t?(a=t,window.tegna.log("_abtest","showingStoredVariant",{test:this.uuid,variant:t})):(a=e[t=e.length,Math.floor(Math.random()*Math.floor(t))].uuid,window.localStorage.setItem(this.uuid,a),window.localStorage.setItem(this.uuid+"_tegna_expire",Date.now()+108e5),window.tegna.log("_abtest","showingNewVariant",{test:this.uuid,variant:a}));const i=async(e,t,i)=>{var n=document.querySelector(".page").dataset.uxTrackingUrl,o=document.querySelector('[name="__RequestVerificationToken"]').value;try{var r=await fetch(n,{method:"POST",headers:{"Content-Type":"application/json",pragma:"no-cache","cache-control":"no-cache","XSRF-TOKEN":o},body:JSON.stringify({testId:this.uuid,siteId:document.querySelector(".page").dataset.siteId,variantId:a,click:e?1:0,impression:t?1:0})});r.ok?r.text().then(e=>{i(e)}):window.tegna.log("_abtest","impressionFailed")}catch(e){window.tegna.log("_abtest","impressionErrored")}};for(var n=0;n<e.length;n++)e[n].uuid===a?(e[n].active=!0,[...e[n].querySelectorAll("a:not([data-ab-click-mode=ignore])")].forEach((t,e)=>{t.addEventListener("click",e=>{e.preventDefault(),e.stopPropagation(),i(!0,!1,()=>{window.location=t.getAttribute("href")}),window.setTimeout(()=>{window.location=t.getAttribute("href")},500)})}),new IntersectionObserver((e,t)=>{e.forEach(e=>{e.isIntersecting?(window.tegna.log("_abtest","attemptingImpression",{el:this,test:this.uuid,variant:a}),i(!1,!0,()=>{window.tegna.log("_abtest","impression",{el:this,test:this.uuid,variant:a})}),t.unobserve(e.target)):window.tegna.log("_abtest","notIntersecting")})}).observe(this)):e[n].active=!1})}}window.customElements.define("tegna-ab",c)}
//# sourceMappingURL=above-page-scripts.js.map</script>
    <div data-module="page" data-state="ready" class="page"
         data-embed="false"
         data-platform="desktop"
         data-page-type="article"
         data-ux-tracking-url="https://abtesting.tegnadigital.com/api/SendUxAbTestingData?code=k/NVP619bs8JWeT/OPqlwVFXPSrr8kouJoZ6/gCw9NE3s2bSOyUjnQ=="
         data-environment="Production"
         data-is-monitor="false"
         data-is-preview="false"
         data-site-id="71"
         data-primarydomain="wgrz.com"
         data-environment-base-url="https://www.wgrz.com/"
         data-call-letters="WGRZ"
         data-full-environment="WGRZ"
         data-twitter-id="WGRZ"
         data-fban="214344422473170"
         data-refresh="420"
         data-dfpid="32805352"
         data-comscoreid="19962895"
         data-recaptchasitekey="6LdhZY8UAAAAANQxx8Y6_JJZSJtONlMiM_yiKTah"
         data-targeting-video_included="false"
         data-targeting-ttid=""
         data-targeting-pgtype="article"
         data-targeting-topic_section=""
         data-targeting-url="https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70"
         data-is-video="false"
         data-is-longform="false"
         data-gptid="NY-Buffalo-WGRZ-B3315_DesktopTablet"
         data-tealium-url="//tags.tiqcdn.com/utag/tegna/wgrz-redesign-desktop/prod/utag"
         data-taboola-url="https://www.etonline.com/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski-195514"
         data-elvs-id="53"
         data-assets-base-url="https://media.wgrz.com"
         data-elvs-stream-url="https://livevideo.tegnadigital.com/wgrz/v1/master/f9c1bf9ffd6ac86b6173a7c169ff6e3f4efbd693/WGRZ/elvs/live.m3u8"
         data-elvs-stream-title="Daybreak"
         data-is-elvs-disabled="false"
         data-hls-js-url="https://amp.akamaized.net/players/9.1.17&#x2B;premier/akamai/amp/core/libs/hls.min"
         data-tealium-id-comscore="1"data-tealium-id-googleanalytics="489"data-tealium-id-oneplusx="606"data-tealium-id-simplifi="557"data-tealium-id-taboola="556"         >
            <div class="page__top">

    <div class="universal-ad" data-module="universal-ad">
        <div class="universal-ad__close-button">
            <img src="/assets/shared-images/icons/close-menu.svg" alt="x" width="14" height="14" />
        </div>
        <div class="universal-ad__ad">
    <div data-module="ad" class="ad ad_position_article_universal ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_universal/entertainment/entertainment-tonight"
         data-sizes="[[1140,250],[970,250],[728,90],[1,1]]"
         data-delay="0"
         data-lazy="false"
         data-position="article_universal"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
    </div>
            </div>
            <div class="page__header">
<header data-module="header" class="header"
        data-alerts="true"
        data-facebook-app-id="214344422473170"
        data-twitter-id="WGRZ">
    <a class="header__skip" href="#main" tabindex="1">Skip Navigation</a>
    <div class="header__main">
        <ul class="header__social-list">
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_facebook" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="facebook">Share on Facebook</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_twitter" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="twitter">Share on Twitter</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_sms" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="sms">Share on SMS</a>
            </li>
            <li class="header__social-item">
                <a class="header__social-link header__social-link_type_email" data-tracking-action="click" data-tracking-category="sharing" data-tracking-label="email">Share on Email</a>
            </li>
        </ul>
        <div class="header__main-inner">
            <div class="header__hamburger">
                <div class="header__hamburger-icon-container" role="button" tabindex="0">
                    <div class="header__hamburger-icon"></div>
                </div>
            </div>
            <a class="header__station-branding" href="/" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="masthead-logo">
                <img class="header__logo" alt="WGRZ Home" src="/assets/shared-images/logos/wgrz.png" loading="eager" width="112" onload="this.parentElement.style.opacity='1';" />
            </a>
            <nav class="header__not-logo">
                <h2 class="header__nav-heading">Navigation</h2>
                <div class="header__tooltip-overlay"></div>
                <ul class="header__nav">
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/news" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="News">
                                        <span class="header__nav-label">News</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/local" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Local">
                                                                    <span class="header__subnav-label">Local</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/near-me" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Near Me">
                                                                    <span class="header__subnav-label">Near Me</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/entertainment" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Entertainment">
                                                                    <span class="header__subnav-label">Entertainment</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/health" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Health">
                                                                    <span class="header__subnav-label">Health</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/money" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Money">
                                                                    <span class="header__subnav-label">Money</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/nation-world" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Nation World">
                                                                    <span class="header__subnav-label">Nation World</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/politics" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Politics">
                                                                    <span class="header__subnav-label">Politics</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/investigations" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="2 Investigates">
                                                                    <span class="header__subnav-label">2 Investigates</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/verify" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                                                    <span class="header__subnav-label">VERIFY</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/shows" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Shows">
                                                                    <span class="header__subnav-label">Shows</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/features" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Features">
                                                                    <span class="header__subnav-label">Features</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest News Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.wgrz.com/article/news/local/2-buffalo-women-help-stabbing-victim-crime-community/71-1e6da901-1148-478b-ac16-a363a3523937" aria-label="Read 2 Buffalo women help stabbing victim" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 2 Buffalo women help stabbing victim">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="2 Buffalo women help stabbing victim" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="2 Buffalo women help stabbing victim" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/5610133b-a54b-4d4f-8df9-7752057e2800/5610133b-a54b-4d4f-8df9-7752057e2800_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.wgrz.com/article/news/local/2-buffalo-women-help-stabbing-victim-crime-community/71-1e6da901-1148-478b-ac16-a363a3523937" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; 2 Buffalo women help stabbing victim">2 Buffalo women help stabbing victim</a></h4>
                    </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.wgrz.com/article/news/local/buffalo/owner-of-louies-on-bailey-says-hes-heartbroken-after-store-was-looted-crime-winter-storm-wny/71-c8858c3c-04c6-4130-9684-e29d150cf2d3" aria-label="Read Owner of Louie&#x27;s on Bailey says he&#x27;s heartbroken after store was looted" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Owner of Louie&#x27;s on Bailey says he&#x27;s heartbroken after store was looted">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Owner of Louie's on Bailey says he's heartbroken after store was looted" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Owner of Louie's on Bailey says he's heartbroken after store was looted" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/d362bc82-8830-4898-ad45-039b9b621379/d362bc82-8830-4898-ad45-039b9b621379_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.wgrz.com/article/news/local/buffalo/owner-of-louies-on-bailey-says-hes-heartbroken-after-store-was-looted-crime-winter-storm-wny/71-c8858c3c-04c6-4130-9684-e29d150cf2d3" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Owner of Louie&#x27;s on Bailey says he&#x27;s heartbroken after store was looted">Owner of Louie&#x27;s on Bailey says he&#x27;s heartbroken after store was looted</a></h4>
                    </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_true" href="/weather/" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather">
                                        <span class="header__nav-label">Weather</span>
                            </a>
                            <div class="header__subnav">
                                <div class="header__subnav-groups">
                                    <div class="header__subnav-group header__subnav-group_name_back">
                                        <ul class="header__subnav-list">
                                            <li class="header__subnav-item header__subnav-item_type_back">
                                                <a class="header__subnav-link header__subnav-link_type_back" href="#">
                                                    <span class="header__subnav-label header__subnav-label_type_back">Back</span>
                                                </a>
                                            </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_topics">
                                        <ul class="header__subnav-list">
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/forecast" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Forecast">
                                                                    <span class="header__subnav-label">Forecast</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/radar" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Radar">
                                                                    <span class="header__subnav-label">Radar</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/10-day" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="10-Day/Hourly">
                                                                    <span class="header__subnav-label">10-Day/Hourly</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/closings" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Closings &amp; Delays">
                                                                    <span class="header__subnav-label">Closings &amp; Delays</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/traffic" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Traffic">
                                                                    <span class="header__subnav-label">Traffic</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/closings-registration" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Closings Registration">
                                                                    <span class="header__subnav-label">Closings Registration</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/weather-cameras" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Weather Cameras">
                                                                    <span class="header__subnav-label">Weather Cameras</span>
                                                        </a>
                                                    </li>
                                                    <li class="header__subnav-item header__subnav-item_type_text">
                                                        <a class="header__subnav-link header__subnav-link_type_text" href="/stem" target="_self" rel="" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="STEM Star Student of the Month">
                                                                    <span class="header__subnav-label">STEM Star Student of the Month</span>
                                                        </a>
                                                    </li>
                                        </ul>
                                    </div>
                                    <div class="header__subnav-group header__subnav-group_name_featured">
                                            <div class="header__featured-title">Latest Weather Stories</div>
<div data-module="story-row" class="story-row">
    <ul class="story-row__list">
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.wgrz.com/article/weather/storm-team-2-weather-forecast-wny-buffalo/71-dae13dab-e703-483f-b2b5-6fc12954e3a7" aria-label="Read Storm Team 2 Weather Forecast" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Storm Team 2 Weather Forecast">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Storm Team 2 Weather Forecast" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Storm Team 2 Weather Forecast" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/f1ea9115-ff1c-4061-ad58-e514b80bc739/f1ea9115-ff1c-4061-ad58-e514b80bc739_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.wgrz.com/article/weather/storm-team-2-weather-forecast-wny-buffalo/71-dae13dab-e703-483f-b2b5-6fc12954e3a7" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Storm Team 2 Weather Forecast">Storm Team 2 Weather Forecast</a></h4>
                    </div>
            </li>
            <li class="story-row__item story-row__item_size_half">
                    <div class="story-row__photo">
                        <div class="story-row__ratio-enforcer">
                            <div class="story-row__ratio-enforced">
                                <a class="story-row__image-link" href="https://www.wgrz.com/article/news/local/buffalo-woman-saves-a-man-from-freezing-to-death-in-blizzard-community-love-help-winter-wny/71-2e7620c5-8cd4-4381-b773-fa6d2e08150b" aria-label="Read Buffalo woman saves a man from freezing to death in blizzard" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Buffalo woman saves a man from freezing to death in blizzard">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="Buffalo woman saves a man from freezing to death in blizzard" width="" height="" src="https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_false" alt="Buffalo woman saves a man from freezing to death in blizzard" width="" height="" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_360x203.jpg" data-srcset="https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_16x9.jpg 16w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_140x79.jpg 140w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_360x203.jpg 360w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_540x304.jpg 540w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_750x422.jpg 750w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_1140x641.jpg 1140w, https://media.wgrz.com/assets/WGRZ/images/3f295573-7a5c-464f-aea8-eb925ee9cb7f/3f295573-7a5c-464f-aea8-eb925ee9cb7f_1920x1080.jpg 1920w" sizes="calc(50vw - 15px)" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script></div>
                                </a>
                            </div>
                        </div>
                    </div>
                    <div class="story-row__text">
                        <h4 class="story-row__title story-row__title_size_half"><a class="story-row__title-link" href="https://www.wgrz.com/article/news/local/buffalo-woman-saves-a-man-from-freezing-to-death-in-blizzard-community-love-help-winter-wny/71-2e7620c5-8cd4-4381-b773-fa6d2e08150b" data-tracking-category="module" data-tracking-action="click" data-tracking-label="storyRow; Buffalo woman saves a man from freezing to death in blizzard">Buffalo woman saves a man from freezing to death in blizzard</a></h4>
                    </div>
            </li>
    </ul>
</div>                                    </div>
                                </div>
                            </div>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/sports" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="Sports">
                                        <span class="header__nav-label">Sports</span>
                            </a>
                        </li>
                        <li class="header__nav-item">
                            <a class="header__nav-link header__nav-link_has-subnav_false" href="/verify" target="_self" data-tracking-action="click" data-tracking-category="navigation" data-tracking-label="VERIFY">
                                        <span class="header__nav-label">VERIFY</span>
                            </a>
                        </li>
                        <li>
                            <div class="header__mini-live-video">
<div data-module="watch-live" class="watch-live watch-live_active_true" data-watch-enabled="true">
    <a class="watch-live__cta" href="/watch">
        <img class="watch-live__logo" src="/assets/shared-images/logos/native/wgrz.svg" alt="Watch Live" />
    </a>
    <div class="watch-live__mini-live-video watch-live__mini-live-video_active_true">
        <a class="watch-live__video-link" href="/watch">
    <div data-module="mini-live-video" class="mini-live-video mini-live-video_state_playing" data-is-watch="false">    
        <div class="mini-live-video__player"></div>
    </div>        </a>
    </div>
</div>                            </div>
                        </li>
                    <li class="header__nav-search header__nav-search_type_search">
                        <a class="header__nav-link header__nav-link_type_search" href="/search">
                            <label class="header__nav-label header__nav-label_type_search" for="site_search">Search</label>
                        </a>
                        <div class="header__subnav header__subnav_type_search">
                            <div class="header__subnav-group header__subnav-group_name_search">
                                <form class="header__search-form" method="GET" action="/search">
                                    <label class="header__search-label" for="site_search">Search:</label>
                                    <input class="header__search-box" placeholder="Search wgrz.com" id="site_search" type="search" name="q" />
                                    <button class="header__search-submit" type="submit">Search</button>
                                </form>
                            </div>
                            <button class="header__close-button" aria-label="close"></button>
                        </div>
                    </li>
                </ul>
                    <div class="header__sponsor">
    <div data-module="ad" class="ad ad_position_masthead_sponsor ad_background_false"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/masthead_sponsor/entertainment/entertainment-tonight"
         data-sizes="[[112,38]]"
         data-delay="0"
         data-lazy="false"
         data-position="masthead_sponsor"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_false" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                    </div>
                <a class="header__weather-link" href="/weather" data-tracking-action="weather-summary/weatherClicked" data-tracking-category="linkClick" data-tracking-label="Link From: https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70" aria-label="Visit the weather page">
                    <div class="header__weather">
                        <div class="header__weather-desktop-info">
                            <div class="header__weather-label header__weather-label_alerts_true">Right Now</div>
                            <div class="header__weather-city header__weather-city_alerts_true">Buffalo, NY &nbsp;&raquo;</div>
                        </div>
                        <div class="header__weather-content">
                            <div class="header__weather-info header__weather-info_alerts_true">
                                <div class="header__weather-temp header__weather-temp_alerts_true">31&deg;</div>

                                <div class="header__weather-icon header__weather-icon_alerts_true">
                                    <div class="lazy-image" data-module="lazy-image" data-blur="false"><img class="lazy-image__placeholder lazy-image__placeholder_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_8x8.png" /><img class="lazy-image__image lazy-image__image_blur_false" alt="" width="26px" height="26px" src="/assets/shared-images/backgrounds/blank.png" data-src="/assets/shared-images/weather-icons/wx-67_32x32.png" data-srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="26px" height="26px" src="/assets/shared-images/weather-icons/wx-67_32x32.png" srcset="/assets/shared-images/weather-icons/wx-67_8x8.png 8w, /assets/shared-images/weather-icons/wx-67_16x16.png 16w, /assets/shared-images/weather-icons/wx-67_32x32.png 32w, /assets/shared-images/weather-icons/wx-67_64x64.png 64w, /assets/shared-images/weather-icons/wx-67_128x128.png 128w, /assets/shared-images/weather-icons/wx-67_210x210.png 210w" sizes="26px" loading="lazy" /></noscript></div>
                                </div>
                            </div>
                            <div class="header__weather-city header__weather-city_alerts_true">Buffalo, NY &nbsp;&raquo;</div>
                        </div>
                    </div>
                </a>
            <div class="header__alerts">
                    <a class="header__alert header__alert_type_weather header__alert_visible_false" href="/weather/alerts" data-tracking-action="weatheralert/linkClicked" data-tracking-category="linkClick" data-tracking-label="Link From: https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70">Weather</a>
                    <a class="header__alert header__alert_type_closings header__alert_visible_true" href="/closings" data-tracking-action="closingsalert/linkClicked" data-tracking-category="linkClick" data-tracking-label="Link From: https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70">Closings</a>
            </div>
            </nav>
        </div>
    </div>
    <div class="header__featured">
            <button disabled class="header__featured-arrow header__featured-arrow_direction_previous"><div class="header__featured-arrow-icon"></div></button>
            <div class="header__featured-inner">
                <ul class="header__featured-list">
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/advertise">Advertise With Us</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/investigativepost">Investigative Post</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/recalls">Recalls</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/vote">VOTE</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/mostbuffalo">Most Buffalo</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/what2do">What 2 Do</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/unknown-stories">Unknown Stories of WNY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/billsfuture">Future of the Bills</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/email">Sign up for newsletter</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.wgrz.com/community">commUNITY</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/closings">Closings</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/instagram">Instagram</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/mentalhealth">Mental Health</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="/tiktok">TikTok</a>
                        </li>
                        <li class="header__featured-item">
                            <a class="header__featured-link" href="https://www.wgrz.com/selflessamongus">Selfless Among Us</a>
                        </li>
                </ul>
            </div>
            <button disabled class="header__featured-arrow header__featured-arrow_direction_next"><div class="header__featured-arrow-icon"></div></button>
    </div>
</header>            </div>
            <div class="page__dock">
                    <div class="page__breaking-news-alerts">
    <div data-module="breaking-news-alerts" class="breaking-news-alerts breaking-news-alerts_visible_false">
        <div class="breaking-news-alerts__wrap">
            <div class="breaking-news-alerts__close"></div>
            <div class="breaking-news-alerts__label">Breaking News</div>
            <ul class="breaking-news-alerts__headline-wrap">
                <template class="breaking-news-alerts__template">
                    <li class="breaking-news-alerts__item">
                        <a class="breaking-news-alerts__link" href="#" data-tracking="breaking-news-alerts/linkClicked">
                            <span class="breaking-news-alerts__headline"></span>
                            <span class="breaking-news-alerts__read-more">Read More &raquo;</span>
                        </a>
                    </li>
                </template>
            </ul>
            <a class="breaking-news-alerts__more" href="/breaking-news" data-tracking="breaking-news-alerts/moreClicked">More (<span class="breaking-news-alerts__count"></span>) &raquo;</a>
        </div>
    </div>
                    </div>
            </div>
        <main class="page__main" id="main">
            <div class="page__grid">
                


<div data-module="grid" class="grid grid_version_2-1">
        <div class="grid__section grid__section_behavior_static grid__section_theme_default" data-behavior="static" data-theme="default" data-cooldown="0" data-name="">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_right grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_article" data-module-sizer="article" data-count="1">
<article class="article" data-module="article"
         data-article-id="5b766038-6f7a-4206-b5d1-7e392b66ee70"
         data-title="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski"
         data-seo-title="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski"
         data-abstract="A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski"
         data-section="entertainment"
         data-subsection="entertainment-tonight"
         data-topic=""
         data-subtopic=""
         data-url="https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70"
         data-pathname="www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70"
         data-gpt-network-code="32805352"
         data-categories="entertainment,entertainment-tonight"
         data-author="Zach Seemayer&#x200D;"
         data-keywords="entertainment,celebrity news,entertainment-tonight"
         data-has-video="false"
         data-watson-keywords="Recap of Pete Davidson,Davidson&#x27;s romances,Davidson&#x27;s magnetic charm,Getty Images,Ariana Grande"
         data-t1-publisher=""
         data-is-cct="false"
         data-original-headline="A Recap of Pete Davidson&amp;#039;s Romantic History: From Cazzie David to Emily Ratajkowski"
         data-content-score=""
         data-tracking-tags="">
            <a class="article__category" href="/section/entertainment-tonight" data-tracking-category="article" data-tracking-action="click" data-tracking-label="article; topic; Entertainment Tonight">Entertainment Tonight</a>
            <h1 class="article__headline">A Recap of Pete Davidson&#x27;s Romantic History: From Cazzie David to Emily Ratajkowski</h1>
            <div class="article__summary">A Recap of Pete Davidson's Romantic History: From Cazzie David to Emily Ratajkowski</div>
        <div class="article__lead-asset">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="750" height="422" src="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="750" height="422" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_750x422.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1920x1080.jpg 1920w" sizes="750px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="750" height="422" src="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_750x422.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/b65366c4-36a0-4c92-b1dc-36f16b766d89/b65366c4-36a0-4c92-b1dc-36f16b766d89_1920x1080.jpg 1920w" sizes="750px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>        </div>
        <aside class="article__meta">
                <div class="article__author">
                    <span class="article__meta-label">Author:</span> Zach Seemayer&#x200D;
                </div>
                <div class="article__published">
                    <span class="article__meta-label">Published:</span> 10:24 PM EST December 27, 2022
                </div>
                <div class="article__updated">
                    <span class="article__meta-label">Updated:</span> 10:24 PM EST December 27, 2022
                </div>
            <div class="article__sharing">
    <div data-module="article-sharing" class="article-sharing">
        <a class="article-sharing__icon" href="https://www.facebook.com/dialog/share?app_id=214344422473170&display=popup&href=https%3A%2F%2Fwww.wgrz.com%2Farticle%2Fentertainment%2Fentertainment-tonight%2Fa-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski%2F603-5b766038-6f7a-4206-b5d1-7e392b66ee70&redirect_uri=https%3A%2F%2Fwww.wgrz.com%2Farticle%2Fentertainment%2Fentertainment-tonight%2Fa-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski%2F603-5b766038-6f7a-4206-b5d1-7e392b66ee70" target="_blank" data-tracking-action="sharing/facebookLink" data-tracking-category="linkClick" data-tracking-label="Link From: https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70">
            <img class="article-sharing__logo" alt="Facebook" src="/assets/shared-images/icons/facebook.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
        <a class="article-sharing__icon" href="https://twitter.com/intent/tweet?text=A%20Recap%20of%20Pete%20Davidson%27s%20Romantic%20History%3A%20From%20Cazzie%20David%20to%20Emily%20Ratajkowski&url=https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70&via=WGRZ" target="_blank" data-tracking-action="sharing/twitterLink" data-tracking-category="linkClick" data-tracking-label="Link From: https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70">
            <img class="article-sharing__logo" alt="Twitter" src="/assets/shared-images/icons/twitter.svg" loading="eager" width="38" onload="this.parentElement.style.opacity='1';" />
        </a>
    </div>            </div>
        </aside>
    <div class="article__body">
                    <div class="article__section article__section_type_text utility__text">
<p><a href="https://www.etonline.com/people/pete-davidson" rel="" target="_blank">Pete Davidson's</a> love life has had more twists, turns, surprises and shocking ends than most soap operas, and it is thrust into the spotlight every time the <a href="https://www.etonline.com/tv/saturday-night-live" rel="" target="_blank"><em>Saturday Night Live</em></a> alum is spotted holding hands with someone new.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The so-called <a href="https://www.etonline.com/kim-kardashian-reveals-why-she-fell-for-pete-davidson-and-what-she-enjoys-doing-most-with-him" rel="" target="_blank">"secret" to Davidson's magnetic charm</a> has been debated and dissected by celebs, co-stars, friendly exes and nearly everyone on Twitter endlessly. It usually boils down to either "he's super funny," or "he's super sweet" or a third, more personal and indiscreet option that everyone knows so we don't need to mention here.</p>                    </div>
                        <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid1 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid1/entertainment/entertainment-tonight"
         data-sizes="[[300,250],[1,1],[750,570],[1,2]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_mid1"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                        </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Regardless of the reasons behind his undeniable charisma and attractiveness, Davidson's romances have stolen the spotlight time and again -- most recently with a <a href="https://www.etonline.com/pete-davidson-and-emily-ratajkowski-make-first-public-appearance-since-sparking-romance-rumors" rel="" target="_blank">high-profile dalliance with Emily Ratajkowski</a> following a long and seemingly serious <a href="https://www.etonline.com/kim-kardashian-reveals-how-much-pete-davidson-is-involved-in-the-kardashians-180544" rel="" target="_blank">romance with Kim Kardashian.</a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>ET is taking a look back at Davidson's dating history and going through each of his headline-grabbing romances over the past several years.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><br><strong>Cazzie David -- May 2016 - May 2018</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/745488aa-043a-4e73-8b06-e99a61726a41/745488aa-043a-4e73-8b06-e99a61726a41_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>C Flanigan/Getty Images</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>One of Davidson's first long-term and serious celeb romances was sparked with <a href="https://www.etonline.com/people/cazzie-david" rel="" target="_blank">Cazzie David</a> -- the daughter of comedian Larry David -- in May 2016. ET caught up with Davidson in April 2017, at the Natural Resources Defense Council's Stand Up For The Planet Benefit gala in Los Angeles, where the two walked the red carpet together. <a href="https://www.etonline.com/news/216082_pete_davidson_thanks_girlfriend_cazzie_david_for_helping_him_stay_sober_i_m_very_lucky" target="_blank">Davidson praised his then-girlfriend</a>, telling ET, "She's the most beautiful girl in the world, look how lucky I am. She's so smart, look how smart she is. She is a very, very wonderful lady."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The young sketch comic also credited David for helping him <a href="https://www.etonline.com/news/212256_snl_pete_davidson_says_he_happy_and_sober_for_the_first_time_8_years_emotional_instagram_post" target="_blank">stay sober after a long struggle with substance abuse</a>, explaining, "I'm very lucky. She's very, very supportive."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>However, in May 2018, Davidson revealed that they'd split up during an interview with Complex's <a href="http://www.complex.com/video/open-late-show/" target="_blank"><em>Open Late with Peter Rosenberg</em></a>. Davidson revealed, "We're not together anymore," but had nothing but kind words for his ex, telling Rosenberg, that she's a "very talented girl" and that "she'll do great, she'll be fine."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><br><strong>Ariana Grande -- May 2018 - October 2018</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/41cc7556-b7b7-4acf-b9f3-09463ab47aa8/41cc7556-b7b7-4acf-b9f3-09463ab47aa8_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Paul Zimmerman/WireImage</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Davidson redefined "whirlwind romance" with his relationship with <a href="https://www.etonline.com/people/ariana-grande" rel="" target="_blank">Ariana Grande</a>. The pair began dating very shortly after his split with Cazzie David, and then revealed they'd <a href="https://www.etonline.com/ariana-grande-and-pete-davidson-engaged-after-less-than-a-month-of-dating-103969" rel="" target="_blank">gotten engaged just one month after</a> they first started dating. </p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Their romance made headlines constantly, and the pair spent a lot of time in the spotlight. Grande even released a song called "Pete Davidson." The comedian appeared in a "Weekend Update" segment on <em>SNL</em>, where he joked about their relationship being somewhat reckless. Then, in October, the pair actually did break up.</p>                    </div>
                                <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid2 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid2/entertainment/entertainment-tonight"
         data-sizes="[[300,250],[1,1]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_mid2"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey="[&#xD;&#xA;  &quot;2YNEkKMk1QC5WsCndTXLDYVB&quot;&#xD;&#xA;]"
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>According to Davidson, a significant part of the reason for their split was the shocking and tragic death of Grande's ex-boyfriend, Mac Miller, who died of a drug overdose in September 2018. Davidson <a href="https://www.etonline.com/pete-davidson-on-predicting-his-engagement-to-ariana-grande-was-off-after-mac-millers-death-142079" rel="" target="_blank">explained to Charlamagne Tha God in February 2020</a> that Miller’s death had an effect on their engagement. "I was like, ‘Listen, I get it, do whatever you’ve got to do, I’ll be here,’” Davidson recalled how he supported Grande as she mourned her ex. “I think I said, ‘I’ll be here until you don’t want me to be here'... I pretty much knew it was around over after that."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><br><strong>Kate Beckinsale -- Jan. 2019 - Apr. 2019</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6/28a29d3b-d3ea-4fd5-b588-0662d94dd8f6_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Kristy Sparow/Getty Images</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Davidson and <a href="https://www.etonline.com/people/kate-beckinsale" rel="" target="_blank">Kate Beckinsale</a> began attracting paparazzi attention in January 2019, after first sparking romance rumors at a Golden Globes party. They were subsequently spotted locking lips in public -- multiple times. </p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>In March 2019,  Beckinsale briefly addressed their whirlwind romance in <a href="https://www.etonline.com/kate-beckinsale-says-pete-davidson-comes-with-his-own-bag-of-mischief-122244" target="_blank">an interview with the <em>Los Angeles Times</em></a>, where she commented on the media scrutiny that comes with dating someone like the <em>Saturday Night Live</em> star. "I've never been in this position before," Beckinsale admitted. "Never dated anybody who comes with their own bag of mischief."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>The next month, <a href="https://www.etonline.com/kate-beckinsale-addresses-hanging-out-with-ex-pete-davidsons-pal-machine-gun-kelly-139177" rel="" target="_blank">the pair had moved on</a>, but a source told ET at the time that they remained friends.<br> </p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>Margaret Qualley -- Aug. 2019 - Oct. 2019</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/4c934198-1869-46d2-ac54-7771f5168bce/4c934198-1869-46d2-ac54-7771f5168bce_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Jemal Countess/Getty Images</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>In one of Davidson's quieter romances, the <em>Meet Cute</em> star was romantically linked to <em>Once Upon a Time... in Hollywood</em> actress <a href="https://www.etonline.com/people/margaret-qualley" rel="" target="_blank">Margaret Qualley</a> for just a few, hand-holding months. Davidson and Qualley sparked romance rumors in August 2019 and were spotted together multiple times throughout September, and in different countries -- namely, in Italy, <a href="https://www.etonline.com/pete-davidson-and-margaret-qualley-fuel-dating-rumors-after-theyre-spotted-out-in-italy-131623" rel="" target="_blank">where they attended the Venice Film Festival</a>. However, the pair called it quits in mid-October. </p>                    </div>
                                <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid3 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid3/entertainment/entertainment-tonight"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_mid3"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>Kaia Gerber -- Nov. 2019 - Jan. 2020</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/3d7daf04-d376-4d70-a696-c1bf9e92db11/3d7daf04-d376-4d70-a696-c1bf9e92db11_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Axelle/Bauer-Griffin/FilmMagic</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Rumors of Davidson's romance with <a href="https://www.etonline.com/people/kaia-gerber" rel="" target="_blank">Kaia Gerber</a> -- the daughter of iconic supermodel Cindy Crawford -- began to swirl at almost the exact moment news broke that he and Qualley had called it quits. Their romance was confirmed in November 2019. They were spotted hanging out a few times, and Davidson even <a href="https://www.etonline.com/pete-davidson-addresses-romance-with-kaia-gerber-implies-hes-going-to-rehab-in-snl-appearance" rel="" target="_blank">addressed the controversy generated by their relationship during an episode of <em>SNL</em></a> in December 2019.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Speaking to "Weekend Update" anchor Colin Jost -- and referring to Jost's <a href="https://www.etonline.com/people/colin-jost" target="_blank">engagement to Scarlett Johansson</a> -- Davidson quipped, "You get to date a famous woman and everyone's delighted, but I do it and America wants to punch me in the throat." Davidson went on to say he didn't understand why people were so mad about it because he was about the best choice Gerber could have when it came to dating guys who look like him. "There's a million guys who look like me and I'm the only one who has a job. It's just me and Tyga."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Davidson went on to say that he was planning on going to rehab during the show's Christmas break. Shortly after, rumors surfaced that Davidson and Gerber had quietly split up.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>Phoebe Dynevor -- March 2021 - August 2021</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/611f3fb4-d71e-4266-9694-22f91765557c/611f3fb4-d71e-4266-9694-22f91765557c_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Karwai Tang/WireImage</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Rumors that <em>Bridgerton</em> star <a href="https://www.etonline.com/people/phoebe-dynevor" rel="" target="_blank">Phoebe Dynevor</a> and Davidson were dating first started swirling in March 2021, when <a href="https://www.etonline.com/are-pete-davidson-and-phoebe-dynevor-dating-pair-spotted-holding-hands-eyewitness-says-162964" target="_blank">an eyewitness told ET</a> that the pair was allegedly holding hands while in the United Kingdom together. That same month, <a href="https://www.etonline.com/pete-davidson-and-phoebe-dynevor-have-gotten-a-bit-more-serious-source-says-163103" target="_blank">a source told ET</a> that Davidson and Dynevor "really hit it off" after meeting at a New York City gathering. The source added that Davidson and Dynevor "traveled between New York City and England to spend time with one another while also working."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>In July 2021, the cute stars <a href="https://www.etonline.com/pete-davidson-and-phoebe-dynevor-cant-stop-smiling-in-adorable-pics-from-wimbledon-168336" rel="" target="_blank">looked totally smitten with each other</a> while attending day six of the Wimbledon Tennis Championships at the All England Lawn Tennis and Croquet Club, in one of their most public outings together. However, by mid-August, ET learned that they had gone their separate ways due to their hectic shooting schedules in different parts of the world.</p>                    </div>
                                <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid4 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid4/entertainment/entertainment-tonight"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_mid4"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>Kim Kardashian -- Nov. 2021 - Sept. 2022</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/71b3e627-1eee-4f9c-90ed-c451423aca90/71b3e627-1eee-4f9c-90ed-c451423aca90_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Dimitrios Kambouris/Getty Images</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>In the romance that would finally overshadow Davidson's brief engagement to Ariana Grande, the comic began dating <a href="https://www.etonline.com/people/kim-kardashian" rel="" target="_blank">Kim Kardashian</a> in October 2021 -- following news that she'd split from husband Kanye "Ye" West, and after Kardashian and Davidson shared an on-screen kiss during the reality star's <em>SNL</em> hosting debut. </p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>Every single aspect of their romance was covered by the press and obsessed over by fans -- and this reached a fever pitch when West began feuding with Davidson on social media, insulting, harassing and threatening him routinely for weeks. Davidson did his best to largely ignore the jabs and kept his relationship largely private. The pair even attended the Met Gala together in one of the largest public displays of their romance.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>When <em>The Kardashians </em>premiered on Hulu in April 2022, fans got more insight into the couple's romance, as Kardashian revealed <a href="https://www.etonline.com/kim-kardashian-describes-how-she-made-the-first-move-with-pete-davidson-i-was-basically-just-dtf" rel="" target="_blank">she'd made the first move</a> with Davidson, and <a href="https://www.etonline.com/kim-kardashian-hints-that-shes-had-the-best-sex-of-her-life-with-pete-davidson-184935" rel="" target="_blank">hinted that she's had the best sex</a> of her life with the comedian. However, the pair ended up splitting in September 2022.  A source told ET at the time that "the distance has been hard and things were starting to fizzle out."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>Emily Ratajkowski -- Nov. 2022 - Dec. 2022</strong></p>                    </div>
                                <div class="article__section article__section_type_photo">


<div data-module="photo" class="photo">
    <div class="photo__image">
        <div class="photo__ratio-enforcer">
            <div class="photo__ratio-enforced">
                <div class="lazy-image" data-module="lazy-image" data-blur="true" style="background-image: url(https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_16x9.jpg)"><img class="lazy-image__placeholder lazy-image__placeholder_blur_true" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_16x9.jpg" /><img class="lazy-image__image lazy-image__image_blur_true" alt="" width="1140" height="641" src="/assets/shared-images/backgrounds/blank.png" data-src="https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1140x641.jpg" data-srcset="https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1920x1080.jpg 1920w" sizes="1140px" /><script>!function(){if (!document.hidden) {let e=document.currentScript;void 0!==window.tegna&&!0===window.tegna.loaded||new window.IntersectionObserver(function(e,a){e.forEach(function(e){if(e.isIntersecting){const a=e.target.querySelectorAll(".lazy-image__image")[0],t=e.target.querySelectorAll(".lazy-image__placeholder")[0];a.src=a.dataset.src,a.srcset=a.dataset.srcset,e.target.dataset.preloaded="true",a.classList.remove("lazy-image__image_loaded_false"),a.classList.add("lazy-image__image_loaded_true"),a.classList.remove("lazy-image__image_blur_true"),a.classList.add("lazy-image__image_blur_false"),t.classList.remove("lazy-image__placeholder_visible_true"),t.classList.add("lazy-image__placeholder_visible_false")}a.unobserve(e.target)})}).observe(e.parentElement)}}();</script><noscript><img class="lazy-image__nojs-image" alt="" width="1140" height="641" src="https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1140x641.jpg" srcset="https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_16x9.jpg 16w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_140x79.jpg 140w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_360x203.jpg 360w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_540x304.jpg 540w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_750x422.jpg 750w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1140x641.jpg 1140w, https://media.wgrz.com/assets/ETONLINE/images/5857bdec-2559-4f24-b758-61190d19ee0b/5857bdec-2559-4f24-b758-61190d19ee0b_1920x1080.jpg 1920w" sizes="1140px" loading="lazy" /></noscript></div>
            </div>
        </div>
    </div>
    <div class="photo__meta">
    </div>
</div>                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p><div>Lexie Moreland/WWD/Penske Media via Getty Images</div></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a href="https://www.etonline.com/people/emily-ratajkowski" target="_blank">Emily Ratajkowski</a> and Davidson were first linked in November, two months after she <a href="https://www.etonline.com/emily-ratajkowski-files-for-divorce-from-sebastian-bear-mcclard-190545" rel="" target="_blank">filed for divorce</a> from her ex, Sebastian Bear-McClard and three months after <a href="https://www.etonline.com/kim-kardashian-and-pete-davidson-still-keep-in-touch-after-breakup-source-says-193232" rel="" target="_blank">Davidson's split</a> from Kardashian. After a source <a href="https://www.etonline.com/pete-davidson-is-seeing-emily-ratajkowski-after-kim-kardashian-split-source-says-194444" rel="" target="_blank">confirmed the romance</a> to ET, the duo <a href="https://www.etonline.com/pete-davidson-and-emily-ratajkowski-seen-in-embrace-for-first-time-amid-dating-reports-pic-194624" rel="" target="_blank">was photographed together</a> for the first time shortly after and went on to have <a href="https://www.etonline.com/pete-davidson-and-emily-ratajkowski-make-first-public-appearance-since-sparking-romance-rumors" rel="" target="_blank">a public date night</a>. That all happened around the same time that a source <a href="https://www.etonline.com/emily-ratajkowski-and-pete-davidson-have-a-good-time-together-inside-their-casual-relationship" rel="" target="_blank">told ET</a> that the model found the <em>SNL </em>alum to be "super charismatic, funny, and a good rebound."</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p>However, things seemed to come to an end before they really started. A source told ET on Dec. 27, that the model and the comedian "have been doing their own things and were never serious." The source added, "Emily finds Pete hysterical, and he thinks she's smoking hot, but they've both been living their lives and not putting any pressure on anything."</p>                    </div>
                                <div class="article__section article__section_type_ad">
    <div data-module="ad" class="ad ad_position_article_mid5 ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_mid5/entertainment/entertainment-tonight"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_mid5"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
        </div>
    </div>
                                </div>
                    <div class="article__section article__section_type_text utility__text">
<p>For more on Davidson's high-profile dating history, check out the video below.</p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><strong>RELATED CONTENT:</strong></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/where-emily-ratajkowskis-relationship-with-pete-davidson-stands-196509">        Where Emily Ratajkowski's Relationship With Pete Davidson Stands     </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/pete-davidson-goes-to-hockey-game-with-bodies-bodies-bodies-co-stars-chase-sui-wonder-and-rachel">        Pete Davidson Goes to Hockey Game With 'Bodies Bodies Bodies' Co-Stars    </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/media/videos/kim-kardashian-is-not-bothered-by-pete-davidsons-relationship-with-emily-ratajkowski">        Kim Kardashian Is 'Not Bothered’ by Pete Davidson's Relationship With Emily Ratajkowski (Source)    </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/martha-stewart-talks-pete-davidson-date-and-holiday-planning-with-mariah-carey-exclusive-194041">        Martha Stewart on Pete Davidson and Holiday Planning with Mariah Carey    </a></p>                    </div>
                    <div class="article__section article__section_type_text utility__text">
<p><a target="_blank" href="https://www.etonline.com/kim-kardashian-reveals-her-pet-name-for-pete-davidson-193446">        Kim Kardashian Reveals Her Pet Name for Pete Davidson     </a></p>                    </div>
    </div>
    <script type="application/ld+json">
        {
  "@context": "http://schema.org",
  "@type": "NewsArticle",
  "headline": "A Recap of Pete Davidson's Romantic History: From Cazzie David to Emily Ratajkowski",
  "datePublished": "10:24 PM EST December 27, 2022",
  "dateModified": "10:24 PM EST December 27, 2022",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "https://www.wgrz.com/article/entertainment/entertainment-tonight/a-recap-of-pete-davidsons-romantic-history-from-cazzie-david-to-emily-ratajkowski/603-5b766038-6f7a-4206-b5d1-7e392b66ee70"
  },
  "author": {
    "@type": "Person",
    "name": "Zach Seemayer‍"
  },
  "publisher": {
    "@type": "Organization",
    "name": "WGRZ",
    "logo": {
      "@type": "ImageObject",
      "url": "https://www.wgrz.com/assets/shared-images/logos/amp/wgrz.png",
      "width": 340,
      "height": 60
    }
  },
  "image": null
}
    </script>
</article>                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_taboola" data-module-sizer="taboola" data-count="1">
    <div data-module="taboola" class="taboola" id="taboola-below-article-thumbnails-2nd-::articleNumber::"
         data-page-type="article"
         data-ad="below_taboola"
         data-mode="thumbnails-h2"
         data-target-type="mix"
         data-placement="Below Article Thumbnails 2nd"
         data-url="https://www.wgrz.com/::contentUrl::"
         data-id="taboola-below-article-thumbnails-2nd-::articleNumber::">
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

                    <div class="grid__sticky-column grid__sticky-column_side_right">
                        <div class="grid__sticky-content" data-columns="1">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
    <div data-module="ad" class="ad ad_position_article_atf ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_atf/entertainment/entertainment-tonight"
         data-sizes="[[300,250]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_atf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_atf/entertainment/entertainment-tonight&amp;sz=300x250&amp;c=698" width="300" height="250" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" data-analytics-name="Right Rail Video Player-1">
                                    <div class="grid__module-sizer grid__module-sizer_name_related-videos" data-module-sizer="related-videos" data-count="1">
    <div data-module="related-videos" class="related-videos">
        <div class="related-videos__player">
        <div data-module="video" class="video video_docked_false"
             data-stream="https://video.tegna-media.com/assets/WGRZ/videos/6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a/6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a.m3u8"
             data-float="false"
             data-thumbnail="https://media.wgrz.com/assets/WGRZ/images/c6dc87d5-4220-45c0-86f4-4911141f8a5b/c6dc87d5-4220-45c0-86f4-4911141f8a5b_1920x1080.jpg"
             data-title="Storm Team 2 Forecast for 12/27/22"
             data-description="Storm Team 2 Forecast for 12/27/22"
             data-site="71"
             data-id="6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a"
             data-mute="true"
             data-autoplay="true"
             data-link="https://www.wgrz.com/video/news/storm-team-2-forecast-for-122722/71-6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a"
             data-origin="video"
             data-section="news"
             data-subsection=""
             data-subcategory=""
             data-topic=""
             data-subtopic=""
             data-categories="news,local,home"
             data-captions=""
             data-tracking-tags=""
             data-is-watch-player="false"
             data-is-live-now="On Demand"
             data-is-ugc="false"
             data-is-cct="false"
             data-ugc-preroll-disabled="true"
             data-duration="234"
             data-disable-preroll-at-duration="0"
             data-disable-preroll="false"
             data-publica-id="9336"
             data-media-tailor-enabled="true"
             data-newscast-preroll-disabled="false"
             data-facebook-app-id="214344422473170"
             data-sharing-twitter-title="Storm Team 2 Forecast for 12/27/22"
             data-sharing-twitter-username="WGRZ"
             data-a9-pubid="3276"
             data-related-autoplay-delay="5"
             data-ama-enabled="false">
            <div class="video__ratio-enforcer">
                <div class="video__ratio-enforced">
                    <noscript><img class="video__fallback" src="https://media.wgrz.com/assets/WGRZ/images/c6dc87d5-4220-45c0-86f4-4911141f8a5b/c6dc87d5-4220-45c0-86f4-4911141f8a5b_1920x1080.jpg" alt="Storm Team 2 Forecast for 12/27/22" /></noscript>
                    <div class="video__docker-container">
                        <div class="video__docker">
                            <button class="video__docker-close" aria-label="undock video"></button>
                            <div class="video__ratio-enforcer">
                                <div class="video__ratio-enforced">
                                    <div class="video__inner">
                                        <div class="video__player-container">
                                            <div class="video__player"></div>
                                            <div class="video__endslate">
                                                <button class="video__endslate-close-button" aria-label="close"></button>
                                                <h4 class="video__endslate-heading">More Videos</h4>
                                                <ul class="video__endslate-list">
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <div class="video__animation video__animation_side_top"></div>
                                                                    <div class="video__animation video__animation_side_right"></div>
                                                                    <div class="video__animation video__animation_side_bottom"></div>
                                                                    <div class="video__animation video__animation_side_left"></div>
                                                                    <img class="video__endslate-thumbnail" src="https://media.wgrz.com/assets/WGRZ/images/c6dc87d5-4220-45c0-86f4-4911141f8a5b/c6dc87d5-4220-45c0-86f4-4911141f8a5b_1920x1080.jpg" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-countdown">Next up in <span class="video__endslate-counter">5</span></p>
                                                            <p class="video__endslate-title video__endslate-title_primary_true">Example video title will go here for this video</p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                    <li class="video__endslate-item">
                                                        <a class="video__endslate-link" href="">
                                                            <div class="video__ratio-enforcer">
                                                                <div class="video__ratio-enforced">
                                                                    <img class="video__endslate-thumbnail" src="" alt="" loading="lazy" />
                                                                </div>
                                                            </div>
                                                            <p class="video__endslate-title"></p>
                                                        </a>
                                                    </li>
                                                </ul>
                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
                <script type="application/ld+json">
                    {
                    "@context": "http://schema.org",
                    "@type": "VideoObject",
                    "name": "Storm Team 2 Forecast for 12/27/22",
                    "description": "Storm Team 2 Forecast for 12/27/22",
                    "thumbnailUrl": "https://media.wgrz.com/assets/WGRZ/images/c6dc87d5-4220-45c0-86f4-4911141f8a5b/c6dc87d5-4220-45c0-86f4-4911141f8a5b_1920x1080.jpg",
                    "uploadDate": "11:26 PM EST December 27, 2022",
                    "duration": "234",
                    "contentUrl": "https://www.wgrz.com/video/news/storm-team-2-forecast-for-122722/71-6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a",
                    "embedUrl": "https://media.wgrz.com/embeds/video/responsive/71-6f6f2c2f-bd73-47ee-b0b2-69d15c5b103a/iframe"
                    }
                </script>
        </div>
        </div>
        <p class="related-videos__topic">In Other News</p>
        <h4 class="related-videos__title">Storm Team 2 Forecast for 12/27/22</h4>
    </div>
                                    </div>
                                </div>
                        </div>
                    </div>
            </div>
        </div>
        <div class="grid__section grid__section_behavior_static grid__section_theme_default" data-behavior="static" data-theme="default" data-cooldown="0" data-name="">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
    <div data-module="ad" class="ad ad_position_article_flex_btf ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_flex_btf/entertainment/entertainment-tonight"
         data-sizes="[[970,250],[728,90],[1140,286],[1,1]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_flex_btf"
         data-refresh-interval="33"
         data-refresh-enabled="true"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_flex_btf/entertainment/entertainment-tonight&amp;sz=970x250|728x90|1140x286|1x1&amp;c=699" width="1140" height="286" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <div class="grid__section grid__section_behavior_static grid__section_theme_default" data-behavior="static" data-theme="default" data-cooldown="0" data-name="">
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__cell grid__cell_columns_3" data-columns="3">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_article-loader" data-module-sizer="article-loader" data-count="1">

<div class="article-loader" data-module="article-loader">
    <button class="article-loader__button"></button>
</div>                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </div>
        <dialog class="grid__section grid__section_behavior_modal grid__section_theme_default" data-behavior="modal" data-theme="default" data-cooldown="1" data-name="exitInterstitial">
                <form method="dialog">
                    <button class="grid__modal-close" aria-label="close"></button>
                <input name="__RequestVerificationToken" type="hidden" value="CfDJ8NdZkYIlzHhKhFJF7ZCePx29PQ5y3WV_K4aF9V5ildIu6KIDQzKtdKWYXXjfKiwzbqfq3eqH42MfqG7GNIsSC7q99qPeK50oueGciiinhcXJK6D9aalg1uoJQA_BFZrumeOYq5zUz_zO7XddhevrCsY" /></form>
            <div class="grid__theme-elements">
                <div class="grid__theme-design-1"></div>
                <div class="grid__theme-design-2"></div>
                <div class="grid__theme-design-3"></div>
                <div class="grid__theme-design-4"></div>
            </div>
            <div class="grid__content grid__content_full-width_false">
                <div class="grid__main grid__main_sticky_none grid__main_full-width_false">
                        <div class="grid__section-header grid__section-header_sponsor-location_right">
                                <h2 class="grid__section-heading">Before You Leave, Check This Out</h2>
                                <img class="grid__modal-logo" alt="WGRZ Home" src="/assets/shared-images/logos/wgrz.png" width="112" />
                        </div>
                        <div class="grid__cell grid__cell_columns_2" data-columns="2">
                                <div class="grid__module grid__module_loaded_false grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_lazy-story-grid" data-module-sizer="lazy-story-grid" data-count="1">
                                            <template class="grid__template">
<div data-module="lazy-story-grid" class="lazy-story-grid"
     data-endpoint="/ajax/content/interstitial"
     data-link-tracking-query="ref=exit-recirc">
    <ul class="lazy-story-grid__list">
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
    </ul>
</div>                                            </template>
                                            <noscript>
<div data-module="lazy-story-grid" class="lazy-story-grid"
     data-endpoint="/ajax/content/interstitial"
     data-link-tracking-query="ref=exit-recirc">
    <ul class="lazy-story-grid__list">
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
            <li class="lazy-story-grid__item lazy-story-grid__item_state_loading">
                <template class="lazy-story-grid__template">
                    <a class="lazy-story-grid__link">
                        <div class="lazy-story-grid__ratio-enforcer">
                            <div class="lazy-story-grid__ratio-enforced">
                                <img class="lazy-story-grid__thumbnail" />
                            </div>
                        </div>
                        <h4 class="lazy-story-grid__title"></h4>
                    </a>
                </template>
            </li>
    </ul>
</div>                                            </noscript>
                                            <script id="module_script_7">
                                                if (window.tegna.supportsJavascript) {
                                                    tegna.loadModule(document.getElementById('module_script_7'), 'lazy-story-grid');
                                                }
                                            </script>
                                    </div>
                                </div>
                        </div>
                        <div class="grid__cell grid__cell_columns_1" data-columns="1">
                                <div class="grid__module grid__module_loaded_true grid__module_padding_full" >
                                    <div class="grid__module-sizer grid__module-sizer_name_ad" data-module-sizer="ad" data-count="1">
    <div data-module="ad" class="ad ad_position_exit_interstitial_display ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/exit_interstitial_display/entertainment/entertainment-tonight"
         data-sizes="[300,250]"
         data-delay="0"
         data-lazy="true"
         data-position="exit_interstitial_display"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_true ad__inner_background_true" style="min-height: 250px; min-width: 300px;">
                    <noscript>
                        <iframe src="https://securepubads.g.doubleclick.net/gampad/adx?iu=/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/exit_interstitial_display/entertainment/entertainment-tonight&amp;sz=&amp;c=700" width="0" height="0" frameborder="0"></iframe>
                    </noscript>
        </div>
    </div>
                                    </div>
                                </div>
                        </div>
                </div>

            </div>
        </dialog>
</div>

            </div>
        </main>
            <div class="page__footer page__footer_theme_default">
<footer data-module="footer" class="footer">
    <div class="footer__outer">
        <div class="footer__inner">
            <div class="footer__logo-wrap">
                <img class="footer__logo" alt="WGRZ-TV" src="/assets/shared-images/logos/wgrz.png">
            </div>
            <div class="footer__menu">
                    <ul class="footer__list" role="list">
                                <li class="footer__item" role="listitem"><a class="footer__link" href="https://www.wgrz.com/wgrz2jobs" target="_blank" rel="noopener">Jobs</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/terms" target="_self" rel="">Terms of Service</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/privacy" target="_self" rel="">Privacy Policy</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/adchoices" target="_self" rel="">Ad Choices</a></li>
                    </ul>
                    <ul class="footer__list" role="list">
                                <li class="footer__item" role="listitem"><a class="footer__link" href="https://interactive.wgrz.com/pdfs/PublicFileReport.pdf" target="_blank" rel="noopener">EEO Public File Report</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/fcc-public-inspection-file" target="_self" rel="">FCC Online Public Inspection File</a></li>
                                <li class="footer__item" role="listitem"><a class="footer__link" href="/closed-captioning" target="_self" rel="">Closed Caption Procedures</a></li>
                                <li class="footer__item footer__item_visible_false" role="listitem"><a class="footer__link footer__link_behavior_show-consent-options" target="_self" href="/do-not-sell-my-information">Do Not Sell My Personal Information</a></li>
                    </ul>
            </div>
            <div class="footer__copyright">
                &copy; 2022 WGRZ-TV. All Rights Reserved.
            </div>
        </div>
    </div>
</footer>            </div>
    </div>
        <div class="page__interstitial">
    <div data-module="ad" class="ad ad_position_article_interstitial ad_background_true"
         data-status="new"
         data-path="/32805352/NY-Buffalo-WGRZ-B3315_DesktopTablet/article_interstitial/entertainment/entertainment-tonight"
         data-sizes="[[1,1]]"
         data-delay="8"
         data-lazy="false"
         data-position="article_interstitial"
         data-refresh-interval="0"
         data-refresh-enabled="false"
         data-targeting-strnativekey=""
         data-collapse="false"
         data-ozone-placement-id=""
         data-ozone-publisher-id="NPID10000003"
         data-ozone-site-id=""
         data-page-type="article">
        <div class="ad__inner ad__inner_border_false ad__inner_background_true" style="min-height: 0px; min-width: 0px;">
        </div>
    </div>
        </div>
        <div class="page__notifications">

<div data-module="notifications" class="notifications" style="display:none">
    <div class="notifications__logo-container">
        <img class="notifications__logo" alt="WGRZ" src="/assets/shared-images/logos/wgrz.png" />
    </div>
    <h2 class="notifications__heading">WGRZ would like to send you push notifications about the latest news and weather.</h2>
    <p class="notifications__description">Notifications can be turned off anytime in the browser settings.</p>
    <div class="notifications__buttons">
        <button class="notifications__button notifications__button_option_no notifications__button_default_false">No Thanks</button>
        <button class="notifications__button notifications__button_option_yes notifications__button_default_true">Allow</button>
    </div>
</div>
        </div>
        <div class="page__toasts">

<div class="toasts">
    <script class="toasts__toast-template" type="text/template">
        <div class="toasts__toast toasts__toast_new_true">
            <div class="toasts__logo-container">
                <img class="toasts__logo" src="/assets/shared-images/logos/wgrz.png" />
            </div>
            <div class="toasts__close">×</div>
            <div class="toasts__content">
                <div class="toasts__title"></div>
                <div class="toasts__body"></div>
                <p class="toasts__link">Read More</p>
            </div>
        </div>
    </script>
</div>        </div>
<div class="modal modal_open_false" data-theme="modal" data-analytics-name="modal">
    <button class="modal__close-button" aria-label="close"></button>
    <div class="modal__content"></div>
</div>    <script src="https://amp.akamaized.net/hosted/1.1/player.esi?apikey=tegna&amp;version=9.1.17"></script>
    <script>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</script>
    <script data-base="/" data-modules="accessibility-statement,ad,adchoices,all-alerts,app-badge,app-promo-link,article,article-loader,article-sharing,article-verify-claim,article-verify-follow-subscribe,breaking-news-alerts,breaking-news-list,carousel,carousel-3up,chapter-slider,closings,connect,countdown,election-single-race,elections,error,footer,from-you,gallery,grid,header,headline-list,hot-races,hot-races-carousel,hourly-graph,iframe,image,lazy-image,lazy-story-grid,live-broadcasts,live-video-banner,longform,mini-live-video,modal,nbc-olympics-live-streams,nbc-olympics-medals-count,nbc-olympics-tv-schedule,newsletter-signup,notifications,olympics-medal-count,page,personal-info,photo,pollen,privacy,question-of-the-day,radar-gallery,raw-html,related-stories,related-videos,right-now-hourly,right-now-radar,scorestream,search,story,story-list,story-row,taboola,text,toasts,tos,traffic-map,universal-ad,video,watch-carousel,watch-content-ad,watch-faq,watch-free,watch-free-cta,watch-free-secondary,watch-live,watch-platforms,watch-secondary-content,weather-10-day,weather-alerts-list,weather-hourly,weather-interactive-radar,weather-maps,weather-nav" data-version="6.11.2">!function(){if(window.tegna.supportsJavascript){var e=document.currentScript.dataset.modules.split(","),s=(e.push("byocarousel"),["page","photo","lazy-image","ad","gallery","video","taboola","related-stories","raw-html","elections","election-single-race"]);for(var a=document.querySelectorAll("[data-module]"),t=0;t<a.length;++t)n=void 0,function(e,s){for(var a=s.length,t=0;t<a;t++)if(s[t]===e)return 1}(n=a[t].getAttribute("data-module"),s)||s.push(n);var r=document.currentScript.dataset.version,i=document.currentScript.dataset.base,l=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.tealiumUrl:"",o=document.getElementsByClassName("page")[0]?document.getElementsByClassName("page")[0].dataset.hlsJsUrl:"";const m={utils:"tegna-utils_"+r,bem:"bem_"+r,"jquery-utils":"jquery-utils_"+r,storage:"tegna-storage_"+r,common:"common.min_"+r,"live-messages":"assets/js-libs/live-messages/live-messages",luxon:"assets/js-libs/luxon/luxon.min",tealium:l,signalr:"assets/js-libs/signalr/signalr.min",hls:o,comscore:"assets/js-libs/comscore/comscore.min",places:"//maps.googleapis.com/maps/api/js?key=AIzaSyBEGr3U4E-OGcjwkhiXfqxfuvOqDQ7Z96c&libraries=places",pgm:"//assets.publicgood.com/pgm/v1/pgm-api","@firebase/app":"firebase-app","@firebase/messaging":"firebase-messaging"};e.forEach(e=>{e in m==!1&&(m[e]=e+"_"+r)}),require.config({baseUrl:i,waitSeconds:30,bundles:{common:["page","universal-ad","header","footer","grid","breaking-news-alerts","tegna-utils","tegna-storage","tegna-tracking","header-updater","byocarousel"]},paths:m,shim:{signalr:{exports:"signalR"},tealium:["jquery"]}}),s.forEach(s=>{try{require([s])}catch(e){console.warn("Module failed: "+s)}})}var n}();
//# sourceMappingURL=configure-require.js.map</script>
        <script data-api-key="AIzaSyCAchbl8p6QgqYvQfGmX_mEVnLm-JtVM5I" data-project-id="wgrz-news-app" data-sender-id="471404531395" data-app-id="1:471404531395:web:16d9c927639acb0d">!function(){var e,a,i,p,t;window.tegna.supportsJavascript&&(e=document.currentScript.dataset,a=e.apiKey,i=e.projectId,p=e.senderId,t=e.appid,require(["@firebase/app","@firebase/messaging"],function(e){e.initializeApp({apiKey:a,authDomain:i+".firebaseapp.com",databaseURL:`https://${i}.firebaseio.com`,projectId:i,storageBucket:i+".appspot.com",messagingSenderId:p,appId:t}),window.firebase=e}))}();
//# sourceMappingURL=firebase.js.map</script>
    <script>!function(){function e(){for(var e,t=document.getElementsByTagName("noscript"),n=0;n<t.length;n++){var r=t.item(n);r.outerHTML=(r=r.innerHTML,e=void 0,(e=document.createElement("textarea")).innerHTML=r,0===e.childNodes.length?"":e.childNodes[0].nodeValue)}}var t,n,r;window.tegna.supportsJavascript||(t=document.body,(n=document.createElement("div")).innerHTML='<div style="background-color:#c50000;font-family:sans-serif;color:#ffffff;text-align:center;"><h2 style="margin:0;padding:10px 0;">Your browser is not fully supported.</h2><p style="margin:0;padding: 10px 0;">For full feature support, please upgrade to a modern browser such as <a href="https://www.microsoft.com/en-us/edge" style="color:#ffffff;" target="_blank">Microsoft Edge</a>.</p></div>',t.insertBefore(n,t.firstChild),e(),r=window.setInterval(function(){document.getElementsByTagName("noscript").length?e():clearInterval(r)},500))}();
//# sourceMappingURL=old-browser.js.map</script>
    <script>tegna.performance.parsed = { time: performance.now() };</script>
    <script>window.performance.mark('tegna_dom_parsed');</script>
    <script>window.tegna = window.tegna || {}; window.tegna.loaded = true;</script>
</body>
</html>
